Hi to Toshiba forum members
My Satellite S50-B has had weird functionality traits with the delete key and the arrow group keys since a Windows 10 update was done sometime before summer of 2018.
I have tried several times to source the fix - reinstalling the keyboard driver, checking drivers, etc with no success to date.
Interestingly enough, I have Virtualbox installed and have discovered that the same troubled keys function just fine in a virtual machine OS running in Virtualbox - so that shows me that "the issue" is not a physical hardware issue with the keyboard.
I have not noticed an issue with any other keys to date.
Can anyone in the forum provide a solution to this problem?
As a note, the laptop (which was bought new by me in Aug 2014 for tech school) has not seen heavy use and has never had Windows wiped or reloaded.
I have only upgraded the OS from OEM Windows 8 Home x64, to 8.1, then lastly to Windows 10 Home x64.
I run MS OS updates frequently to stay ahead of trouble.
This issue seems to involve a driver incompatibility with Windows 10.
Laptop history - I had a similar function issue with the touchpad while it was 8.1 which was finally corrected with an OS update.
Any help would be appreciated.