OK so i have just received an older laptop that im trying to resurrect.



  • O/S : Windows 7
  • Model : Toshiba satellite L500 PSLS3A-04M002
  • Battery model NO : PA3534U-1BRS

It died a few days ago and refuses to boot, press the power button -> power LED glows briefly and goes out.


As it's a smart battery you can't boot directly off the AC adaptor because it's expecting a signal over the SMBus (IIRC) power LED doesn't even light up with A/C only with the battery is removed.


I believe it's the battery.


First because i disassembled the laptop, cleaned it, and put it back together, nothing seemed wrong with other system components.


Second, it's only a small 3620mAh Li-ion that (AFAIK) hasn't been changed since the laptop was bought (roughly 2011/2012) so im thinking the charge cycles have been well and truly used up.


OK no problem, searched around online using the battery model number (above), found a replacement

Cool, battery's enroute, should be here in the next few days.

Now the interesting part... When i go on Toshiba's site to look for some specs/drivers... the Laptop model doesn't exist, even under the discontinued models section... But there are a whole bunch of other models :

http://www.mytoshiba.com.au/products...llite/pro/l500
(click on the little arrow)

Also, there's no live / website or email based technical support :

http://www.mytoshiba.com.au/customer-contact/support

Convenient huh...

Can anyone enlighten me on Toshiba product numbers or point me to a resource for specs and drivers?