Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 8 of 8

Thread: Problem with wireless on Ubunti 16.04 running on Toshiba Satellite C55-C-184

  1. Problem with wireless on Ubunti 16.04 running on Toshiba Satellite C55-C-184
    #1
    Beginner
    Join Date
    Apr 2017
    Location
    London
    Posts
    5
    I've done a number of Linux installations, but they were all either pretty much straight out-of-the-box JEDI installations with a UFO box or installations on Raspberry Pi. This is my first installation on a laptop. The Toshiba C55-C-184 came with Windows 10 pre-installed. I replaced this with Ubuntu 16.04 (I need to install ROS on Ubuntu 16.04 for an online robotics course) however it looks like I'm failing at the first hurdle!

    I've searched the forums but so far I can't find anything that helps. Here is some diagnostic info:

    Running lspci -knn gives:

    lspci -knn | grep -EA2 'Eth|Net'
    Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev cb)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8170]
    Kernel driver in use: iwlwifi02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)
    Subsystem: Toshiba America Info Systems RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [1179:f840]
    Kernel driver in use: r8169
    Kernel modules: r8169So the laptop is using the Intel Corporation Wireless 3160 network controller

    The output from rfkill list all is:

    rfkill list all
    0: Toshiba Bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no


    and running dmesg | grep iwl gives:

    dmesg | grep iwl
    [ 13.853351] iwlwifi 0000:01:00.0: loaded firmware version 17.352738.0 op_mode iwlmvm
    [ 14.047392] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
    [ 14.047499] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
    [ 14.047807] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
    [ 14.165552] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
    [ 15.122708] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
    [ 29.782151] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
    [ 29.782459] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
    [ 29.892142] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
    [ 29.892517] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled



    Any help will be appreciated. Especially if you can explain why it's not working (as well as how I can fix it!) since I'm always happy to expand my working knowledge of Linux.




  2. Re: Problem with wireless on Ubunti 16.04 running on Toshiba Satellite C55-C-184
    #2
    Senior Member
    Join Date
    Sep 2010
    Location
    Sweden
    Posts
    277
    Hi

    What is your problem more exactly?
    And please paste the output showing the wireless details from lspci -knn without piping it through grep.

    BR Tom

  3. Re: Problem with wireless on Ubunti 16.04 running on Toshiba Satellite C55-C-184
    #3
    Beginner
    Join Date
    Apr 2017
    Location
    London
    Posts
    5
    Hi Tom.

    The problem is that The connection manager menu shows Wifi Network disconnected, None of the available wireless networks are displayed when I open Networks, and the wifi key (Fn + F13) seems to be disabled. This model does not appear to have a physical wifi on/off switch, and I can't see anything in the BIOS that looks like it would cause this problem.

    In short, wireless networking does not seem to be working at all, and I can't see any obvious reason why.

    Here is the output from lspci -knn -

    lspci -knn
    00:00.0 Host bridge [0600]: Intel Corporation Device [8086:2280] (rev 21)
    Subsystem: Toshiba America Info Systems Device [1179:f840]
    Kernel driver in use: iosf_mbi_pci
    00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:22b1] (rev 21)
    Subsystem: Toshiba America Info Systems Device [1179:f840]
    Kernel driver in use: i915
    Kernel modules: i915
    00:13.0 SATA controller [0106]: Intel Corporation Device [8086:22a3] (rev 21)
    Subsystem: Toshiba America Info Systems Device [1179:f840]
    Kernel driver in use: ahci
    Kernel modules: ahci
    00:14.0 USB controller [0c03]: Intel Corporation Device [8086:22b5] (rev 21)
    Subsystem: Toshiba America Info Systems Device [1179:f840]
    Kernel driver in use: xhci_hcd
    00:1a.0 Encryption controller [1080]: Intel Corporation Device [8086:2298] (rev 21)
    Subsystem: Toshiba America Info Systems Device [1179:f840]
    Kernel driver in use: mei_txe
    Kernel modules: mei_txe
    00:1b.0 Audio device [0403]: Intel Corporation Device [8086:2284] (rev 21)
    Subsystem: Toshiba America Info Systems Device [1179:f840]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
    00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:22c8] (rev 21)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
    00:1c.1 PCI bridge [0604]: Intel Corporation Device [8086:22ca] (rev 21)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
    00:1c.2 PCI bridge [0604]: Intel Corporation Device [8086:22cc] (rev 21)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
    00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:229c] (rev 21)
    Subsystem: Toshiba America Info Systems Device [1179:f840]
    Kernel driver in use: lpc_ich
    Kernel modules: lpc_ich
    00:1f.3 SMBus [0c05]: Intel Corporation Device [8086:2292] (rev 21)
    Subsystem: Toshiba America Info Systems Device [1179:f840]
    Kernel modules: i2c_i801
    01:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev cb)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8170]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi
    02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)
    Subsystem: Toshiba America Info Systems RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [1179:f840]
    Kernel driver in use: r8169
    Kernel modules: r8169
    03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader [10ec:5229] (rev 01)
    Subsystem: Toshiba America Info Systems RTS5229 PCI Express Card Reader [1179:f840]
    Kernel driver in use: rtsx_pci
    Kernel modules: rtsx_pci

    I hope you can spot something that I've missed. Any help will be greatly appreciated.

    Iain

  4. Re: Problem with wireless on Ubunti 16.04 running on Toshiba Satellite C55-C-184
    #4
    Senior Member
    Join Date
    Sep 2010
    Location
    Sweden
    Posts
    277
    Hi

    I can see others with the same WLAn card as you got on Debian based distros experiencing identical problems.
    The solution seem to boil down to the following - assuming you are able to get internet access??? If not, then you need to find a connection somehow:

    sudo apt install firmware-iwlwifi
    modprobe -r iwlwifi ; modprobe iwlwifi

    The thread I found is this one:
    https://forums.bunsenlabs.org/viewtopic.php?id=1289

    BR Tom

  5. Re: Problem with wireless on Ubunti 16.04 running on Toshiba Satellite C55-C-184
    #5
    Beginner
    Join Date
    Apr 2017
    Location
    London
    Posts
    5
    Hi Tom.

    Thanks for this. I'd seen this (or something similar to it), but they are all for different Linux distributions. I've got the latest version of iwlwifi (checked on the Intel site), so I don't think that is the problem. It seems the firmware-linux-nonfree and firmware-iwlwifi firmware packages aren't actually available (or required) or Ubuntu 16.04.

    I have managed to get hold of a USB wifi adaptor which allowed me to get on line (albeit slowly), but I'd still like to know what the problem is with the built-in wifi. I contacted Toshiba Support,but it seems they can only help if I restore Windows 10 as the OS.

    It's a very strange problem.

  6. Re: Problem with wireless on Ubunti 16.04 running on Toshiba Satellite C55-C-184
    #6
    Senior Member
    Join Date
    Sep 2010
    Location
    Sweden
    Posts
    277
    Hi again

    Something just struck me - you tell me FN+F13 does not work "and the wifi key (Fn + F13) seems to be disabled"
    I assume you're actually talking about F12 not F13 since that key does not exist according my knowledge...

    Anyway, let's see if this is a hint forward:
    The FN-key mapping is changed since some years back. So you should possibly also try pressing ONLY the F12 (not with FN!).
    You can verify which mapping is active (this is changeable in BIOS) by using working keys and compare.
    Let's say you try changing display-brightness by F2 and F3.
    Do you use them with FN or without?
    If without, then apply same logic to the F12 key and vice-versa of course.

    Let us know the outcome and how this affect your situation with the F12 and if that in turn affect the Wireless or not.

    FYI - I tried the 3160-card in a brother-model, C55D-C and with Ubuntu 1604 (updated to be in phase with now) this work fine.

    BR Tom

  7. Re: Problem with wireless on Ubunti 16.04 running on Toshiba Satellite C55-C-184
    #7
    Beginner
    Join Date
    Apr 2017
    Location
    London
    Posts
    5
    Hi Tom.

    Yes, the F13 was a typo and it should have been F12.

    I tried pressing both with and without the Fn key, but no joy. The brightness works with F2 and F3 without pressing the Fn as you said, but not the F12.

    I did read on another site that the Satellite C55-C requires a Toshiba windows driver to set the wifi switch. They suggested setting the laptop up as dual-boot with Windows/Ubuntu as the solution (which would be a pain, but potentially do-able).

  8. Re: Problem with wireless on Ubunti 16.04 running on Toshiba Satellite C55-C-184
    #8
    Beginner
    Join Date
    Apr 2017
    Location
    London
    Posts
    5
    Just to update on the problem.

    In the end I gave up and sent the laptop back to Toshiba under warranty. It turns out that there was a problem with the laptop's cable harness which they had to replace. It arrived back this morning and now WiFi is working perfectly.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •