Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 2 of 2

Thread: BDX1200/KB not detected properly by Pioneer AV receiver

  1. BDX1200/KB not detected properly by Pioneer AV receiver
    #1
    Beginner
    Join Date
    Mar 2017
    Location
    UK
    Posts
    1
    Hi -

    I've just replaced my old Sony STR-DN840 AV receiver with a new Pioneer VSX-1131, and I've got everything working fine, except:

    It doesn't appear to detect my Toshiba BDX1200KB Blu-ray player properly. Or indeed my Toshiba BDX1200 player which I've also tried it with.

    When I say it doesn't detect it, what actually happens is:

    1. AV receiver is switched to BD/DVD channel (HDMI 1 - HDCP 2.2)
    2. I switch the BD player on.
    3. The blue Toshiba Blu-ray home screen appears on screen, and the receiver displays HDMI. So far, so good.
    4. But after a few seconds, the screen goes black and the HDMI indicator on the receiver starts flashing.
    5. Then the blue Toshiba screen re-appears, but the HDMI indicator goes out, audio is detected as "ANALOG", and on playing any disc, I get picture but no sound.

    Also, and I'm guessing for the same reason, if I set the BD player's colour space to YcbCr422, the picture is heavily distorted: all red and noisy. If I set it to YcbCr it's less distorted, but all pink. Only RGB and Full RGB give a normal image. Interestingly, this doesn't apply to the first few seconds where the HDMI indicator is lit: for that brief time the Blu-ray home screen is displayed properly.

    I'm pretty sure my audio output settings on the BD player are correct -

    Spdif: Off
    HDMI: Bitstream
    Down_samp: 48K
    DRC: Off

    - but I've tried literally every possible combination and none of them has worked. And besides, as I say, I've come to the conclusion that the player's simply not being detected properly, rather than it being specifically an audio issue.

    The receiver gives the following information:

    [Video] BD/DVD
    HDMI 1
    1920 x 1080p 24Hz --> 4K
    RGB 24bit DVI

    [Audio] BD/DVD
    Input: ANALOG
    Output: Extended Stereo 5.0ch

    I have no idea why it thinks the input is analog, given that both HDMI 1 and HDMI 2 are set to digital/HDMI on the receiver. For comparison, the info for HDMI 2 is:

    [Video] TIVO
    HDMI 2
    1920 x 1080i 50Hz
    YCbCr444 24 bit

    [Audio] TIVO
    Input: HDMI 2, Dolby D, 2.0ch 48Hz
    Output: Auto Surround, 2.0ch

    Swapping the devices around so that the BD player is using HDMI 2 and the TiVo is using HDMI 1 gives exactly the same results, ie YCbCr444 video and Dolby Digital audio from the TiVo, and RBG video and no sound (reported as Analog/Extended Stereo) from the BD player.

    Furthermore, I've also tried plugging the BD player into the HDMI 6 channel, which doesn't support HDCP 2.2. When I did that, everything looked like it was working properly (even with YcbCr422 selected), until I started playing a disc, at which point there was no video output at all to the TV, but this time I was getting audio - so, the opposite of when it's plugged into HDMI 1, in a sense.

    I have of course tried several different HDMI cables - different brands, different specs, etc, but always get the same results. I've also tried a factory reset on the player, and that didn't make any difference either. I've now restored it to the latest firmware.

    Can anyone give me some help please?

    Thanks
    Cliff

  2. Re: BDX1200/KB not detected properly by Pioneer AV receiver
    #2
    Bit of a late response, but I have the same player that's been great for years.
    Upgraded tv/av receiver and suffer the same issue as you.
    Found the fix on the Marantz forum, while using it, disable Ultra HD True Deep Colour (thats what it is called on my LG Oled in the general settings).
    After spending hours swapping cables etc, I came across your thread, so thank you, you gave me the incentive to search elsewhere.

    Works a treat btw, so hopefully you have kept it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •