Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 5 of 5

Thread: Satellite P70-A - No sound on any devices through HDMI

  1. Satellite P70-A - No sound on any devices through HDMI
    #1
    Beginner
    Join Date
    Dec 2016
    Location
    Romania
    Posts
    1
    Hi, i have a P70-A laptop, model PSPLPC-01Y007, with an I7 4700MQ CPU and Intel HD 4600 gpu. I run Windows 10 PRO and i can't get any sound on any device through HDMI connection. I tried every solution regarding drivers, cables, connectors and many others but i can't fix it. The only moments when i can get the HDMI output in Playback devices is when i install a new driver for video card and i have the HDMI cable connected to laptop. It appears for few second then dissapear and won't appear or work. I tried every driver for this video card from 2013 till now. Same thing. Please tell me what can i do or try.

  2. Re: Satellite P70-A - No sound on any devices through HDMI
    #2
    I've experienced the same problem.

    You must install windows in UEFI mode (4 partitions). I mean UEFI Boot must be enabled in the bios or the tv doesn't show up as a sound device. I believe Secure boot doesn't to be enabled.

    When you install win7 the two of them must be disabled, since win7 installs in MBR mode.

    I believe it is a firmware bug.

    Hope Toshiba engineers are watching.


  3. Re: Satellite P70-A - No sound on any devices through HDMI
    #3
    Quote Originally Posted by radu.postole View Post
    Hi, i have a P70-A laptop, model PSPLPC-01Y007, with an I7 4700MQ CPU and Intel HD 4600 gpu. I run Windows 10 PRO and i can't get any sound on any device through HDMI connection. I tried every solution regarding drivers, cables, connectors and many others but i can't fix it. The only moments when i can get the HDMI output in Playback devices is when i install a new driver for video card and i have the HDMI cable connected to laptop. It appears for few second then dissapear and won't appear or work. I tried every driver for this video card from 2013 till now. Same thing. Please tell me what can i do or try.


    I've experienced the same problem.

    You must install windows in UEFI mode (4 partitions). I mean UEFI Boot must be enabled in the bios or the tv doesn't show up as a sound device. I believe Secure boot doesn't to be enabled.

    When you install win7 the two of them must be disabled, since win7 installs in MBR mode.

    I believe it is a firmware bug.

    Hope Toshiba engineers are watching.

    https://forum.toshiba.eu/showthread....ght=hdmi+sound

  4. Re: Satellite P70-A - No sound on any devices through HDMI
    #4
    Beginner
    Join Date
    Aug 2017
    Location
    Вели&#
    Posts
    2
    I did not find a suitable topic, but judging by the answer, georgegr1 understands this.
    So, I have the following problem - I have long dreamed of a beautiful and practical place for my PC. I finally built my gaming computer and decided to translate into reality my long-standing desire - three monitors working together. I have three outputs from the video card - DisplayPort, HDMI and DVI. And now the actual question is how do I assign all three monitors so that the sound signal would go only on the central one ( I have built-in speakers there) but did not go to the other two (there are speakers too, but much worse)
    I think that the simplest solution is to connect via HDMI splitter, but can someone have a better solution?
    1) My video card - https://www.msi.com/Graphics-card/Ge...#hero-overview
    2) Central monitor (yes I know that this is exatly tv, but it wil be the central monitor) - http://www.toshiba.co.uk/discontinue...art-3d-led-tv/
    3) Possible splitter (I'm not very versed in cables, so advice on the right splitter is welcome) - https://www.bestadvisers.co.uk/hdmi-splitters
    Thank you in advance.
    sincerely, Alakey.

  5. Re: Satellite P70-A - No sound on any devices through HDMI
    #5
    Beginner
    Join Date
    Aug 2017
    Location
    Вели&#
    Posts
    2
    Anybody?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •