Hi

I ordered a Toshiba recovery USB. It cost me 40! But it doesn't work. I need to restore my system because my entire hard disk - including the recovery partition - was wiped clean by a virus. A laptop repair person put a cheap version of Windows 8 on for me, but it is not the full version and various things - such as the DVD player - don't work. I need to reinstall to factory settings.

My USB ports are working fine. When I am in Windows, I can view the contents of the USB stick I have been sent. It contains various folders and files, including a "BOOT" folder and a "BOOTMGR" file.

I have been into the UEFI settings and made the following changes:
Disabled Secure Boot
Changed the Boot Order so that USB is top of the list
Changed the Boot Mode from UEFI to CSM

When I restart the machine with these settings in place, I get the message "No bootable device - insert boot disk and press any key".

I have four USB ports and I have tried plugging the USB stick into every single one of them, but I get the same error every time.

HELP!