Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 4 of 4

Thread: Tecra Z40-A-11L - Can't install Intel HAXM - VT-x not recognized in Win7

  1. Tecra Z40-A-11L - Can't install Intel HAXM - VT-x not recognized in Win7
    #1
    Hello,

    I have a Tecra Z40-A-11L and I'm using it to develop Android applications, using both GNU/Linux and Windows.

    When running AndroidStudio in Ubuntu, I have no problems. When I use it in Win7, I can't get the virtualization to work.

    When I try to use an x86 emulator in the AndroidStudio IDE, I get and error saying that I need to install HAXM support and enable VT-x. In the BIOS the VT-x is enabled. I've tried selecting the options of VT-d + VT-x and VT-x only, and in both cases it still doesn't work. I've tried installing HAXM separately using the Intel installer directly and I get a similar error:

    "This computer meets the requirements for HAXM, but Intel Virtualization Technology (VT-x) is not turned on. HAXM cannot be installed until VT-x is enabled."

    Click image for larger version. 

Name:	HAXM  Error.PNG 
Views:	4 
Size:	14.3 KB 
ID:	263

    As I say, VT-x is enabled in the BIOS, I manage to get virtualization in GNU/Linux, but for some reason Win7 doesn't seem to be able to recognize it..


    Does anyone have a similar problem? Is there something I can do to solve this?

    Thanks,
    Javier

  2. Re: Tecra Z40-A-11L - Can't install Intel HAXM - VT-x not recognized in Win7
    #2
    Master
    Join Date
    Jan 2006
    Posts
    2,568
    The CPU supports definitely the VT-X and you said also that this feature is already enabled in BIOS.

    Therefore I recommend you to check this:
    Turn the whole Hyper-V "Feature" off.
    Open "Control Panel -> "Programs" -> "Turn Windows features on or off"
    (under "Programs and Features") and locate "Hyper-V"
    Now uncheck and reboot the notebook.

    Feedback appreciated.

  3. Re: Tecra Z40-A-11L - Can't install Intel HAXM - VT-x not recognized in Win7
    #3
    Finally I solved the issue.

    In the end the problem was Avast Antivirus that somehow messed up the installation.
    I had to uninstall it, install the HAXM (which then runes smoothly and without a hiccup) and then reinstall the antivirus.

    Also, my windows didn't have Hyper-V installed (I don't mean it wasn't activated, I had to ACTUALLY install it).
    I'm not sure if this also played a part in my problem but, just in case, now it's installed and activated.

    Thank you very much for the help, Jimi.

  4. Re: Tecra Z40-A-11L - Can't install Intel HAXM - VT-x not recognized in Win7
    #4
    Master
    Join Date
    Jan 2006
    Posts
    2,568
    Great news! Thanks for the nice feedback!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •