Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 2 of 2

Thread: Satellite Z30-B-100 - enabled touchpad not working

  1. Satellite Z30-B-100 - enabled touchpad not working
    #1
    I just turned on the laptop and as was trying to set up wifi connections the touchpad stopped working.

    I tried the Fn+F9 but nothing changed. I turned the laptop off and then back on without any results.

    I can work connecting a usb mouse, but the touchpad is still not working.

    Do you have any solution or do I have to take it to be repaired?

    I bought it one week ago and I just had office and antivirus installed and was working perfectly well up until now.

    Thank you

  2. Re: Satellite Z30-B-100 - enabled touchpad not working
    #2
    Senior Member
    Join Date
    Aug 2015
    Posts
    350
    Does the touchpad work in the BIOS?

    If not, it may be a hardware problem, or it is simply disabled in the BIOS.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •