Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 9 of 9

Thread: Fingerprint Utility on Portege Z30-A-12Q is not working

  1. Fingerprint Utility on Portege Z30-A-12Q is not working
    #1
    Beginner
    Join Date
    Feb 2015
    Posts
    5
    Hello,

    I need help regarding this issue :

    I performed a fresh windows 8.1 install, the same version as before, but this time i chose UEFI over BIOS. When i used BIOS the fingerprint sensor was working fine, but now it says "Failed to connect to the sensor".

    I am using Toshiba Portege Z30-A-12Q i5-4200 256 GB SSD, or the PT243E model. I searched the forums and i found a issue similar with another Toshiba R product which was resolved by adding a firewall exception.

    I added fingerprint utility in firewall exception, even disabled firewall all the way, but still the same problem. Also in device manager i have under Biometric devices Validity Sensors (WBF) (PID=0010).

    I also checked in BIOS to see if it it enabled and it is.
    The only thing i changed in BIOS are Secureboot (made it on) and chose CSM (for UEFI), but i think these settings have no relevance to the problem since they are used for booting.

    I tried uninstalling and reinstalling the driver 3 times.

    Please help me with this problem.
    Thank you very much,
    Andrei Chitescu

  2. Re: Fingerprint Utility on Portege Z30-A-12Q is not working
    #2
    The UEFI / CSM boot mode has no influence on the fingerprint sensor.

    You said that you performed an clean Win 8.1 installation.
    I guess the issue is related to missing driver or utility.
    I guess you did not install all essential software available on the Toshiba EU driver page.

    Toshiba System Driver for Win 8.1 should be installed. This is very important driver package.

    But try also to enroll the fingerprints firstly in Windows settings.
    Go to control panel ? Hardware & Sound ? Biometric Devices
    At the left click on “Change Biometric settings”
    Now you will see two options: Biometric ON (marked) and Biometric OFF (not marked)
    Now switch to Biometric OFF and save changes
    Now go back and click again on “Change Biometric settings”
    Now switch back to Biometric ON and save changes.

    Now you should click on “Use your fingerprints with Windows” and enroll the fingerprints.

    I think this could be helpful to get the fingerprint utility working again.

  3. Re: Fingerprint Utility on Portege Z30-A-12Q is not working
    #3
    Beginner
    Join Date
    Feb 2015
    Posts
    5
    Hello MisterX and thank you for your reply.

    I've checked that twice, and also uninstalled and reinstalled all drivers from toshiba, even performed another clean install of windows 8.1, but the problem persists. At the moment i have installed on my notebook the following toshiba drivers : eco Utility, Fingerprint Utility, Function Key, PC Health Monitor, Service Station, System Driver, System Settings, TEMPRO, Validity WBF ( which i guess it is also from Toshiba, even if the publisher is Validity Sensors, Inc. ) O2Micro, all Intel Drivers, ALPS Touchpad. From my point of view i didnt miss anything.

    Also I've tried going to Control Panel -> Hardware..... but Biometric Devices isnt there. I've searched it in the main Windows 8.1 window and still no results. The only thing that appears is " Set up fingerprint sign-in" and when i click on it the fingerprint is greyed out, which is normal since the sensor cannot be found. I downloaded the drivers from the official website directly.

  4. Re: Fingerprint Utility on Portege Z30-A-12Q is not working
    #4
    At this point I’m not quite sure if it’s really a software related issue.

    Just one question: did you use this fingerprint utility before you have installed the new, clean Windows 8.1 system?
    To be honest I’m out of idea…

    Everything what I could suggest you is to load the default settings in BIOS (F9 load default settings, F10 saves the changes).

    Also an usage of Toshiba Recovery Medium would be advisable just to test the fingerprint utility with the Toshiba preconfigured system.

  5. Re: Fingerprint Utility on Portege Z30-A-12Q is not working
    #5
    Beginner
    Join Date
    Jan 2015
    Posts
    4
    I recently got a Techra Z40a running Windows 7 64-bit and have the same issue.

    I downloaded the driver from the Toshiba drivers site. The Windows Biometetric settings are all correct showing that enabled but Windows reports that no sensors are detected. This is despite that the drivers are installed.

    The BIOS settings are all default

    Really frustrating.

  6. Re: Fingerprint Utility on Portege Z30-A-12Q is not working
    #6
    Beginner
    Join Date
    Feb 2015
    Posts
    5
    I change to the default settings in BIOS, but no change so far. I'll go with the notebook at a repair service to check if the sensor has problems, and i'll post the results. I've tried everything so far, the only variable that changed from the time that the sensor was working was the booting to UEFI and the antivirus, but I've disabled that, and tried to access the Fingerprint utility before installing antivirus, and no change so the only thing that remains changed it's the UEFI booting.

  7. Re: Fingerprint Utility on Portege Z30-A-12Q is not working
    #7
    Beginner
    Join Date
    Jan 2015
    Posts
    4
    Well mine is working now.

    After installing the Proset Ethernet drivers/software from Toshiba support drivers download page, the sensor driver "(WBF) (PID=0010)" was recognised and the driver installed.

    Makes no sense whatsoever, but keen to hear if works for others too

  8. Re: Fingerprint Utility on Portege Z30-A-12Q is not working
    #8
    Beginner
    Join Date
    Feb 2015
    Posts
    5
    Mine works too. Installed the chipset driver two times and it worked. Althout, my driver installation makes more sense that the proset wireless i cant see a pattern here.

    Happy to see it works.

  9. Re: Fingerprint Utility on Portege Z30-A-12Q is not working
    #9
    This is very interesting : what do you mean by "Installed the chipset driver two times" ?

    I have exactly the same problem with a Portégé R30A-19Q.
    Changed over from Win 7 to Win 8.1 (one of the worst decisions in my life ! What a disappointment !
    Productivity down by a factor 3 or 4 ! But this is another subject !).

    Tried to reinstall the fingerprint recognition, which did not accept my fingerprints (because "already used on another account").
    Called French technical support, who recommended uninstalling the fingerprint recognition software, which would erase my previous Win 7 fingerprints, left over in the BIOS.

    Then after reinstalling the software, it did not work any better.

    Called again technical support, who gave me a "confidential" link to a fingerprint clean up software, that would remove the fingerprints left over in the BIOS.

    This did not work either, because the installation could not find ATWBFClient.dll.
    Called again technical support, and was told that there was no other solution than reinstalling Win7, then erasing my fingerprints under Win 7, then reinstalling Win 8.1, and recreating new fingerprints ! What a nightmare !

    If anything can be done Under Win 8.1, I shall try ten times !

    Thanks !

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •