Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 4 of 4

Thread: Satellite Pro C50-A-1E2: Problem entering BIOS after fast boot activation

  1. Satellite Pro C50-A-1E2: Problem entering BIOS after fast boot activation
    #1
    Beginner
    Join Date
    Dec 2014
    Posts
    2
    Hello,

    I own Satellite Pro C50-A-1E2.

    Default hdd has been replaced by a kingston v300 ssd.I also activated fast boot.
    I'm desperately trying to enter BIOS but without success.

    I tried every possible combination(Esc,delete,f1,f2,f8,fn+esc,fn f1...)

    I found that piece of info via googling : "hold down f2 then press power".But still no success.
    Any help with my problem?

    Thanks.

  2. Re: Satellite Pro C50-A-1E2: Problem entering BIOS after fast boot activation
    #2
    Hi

    Fast boot can be enabled and disabled also using the Toshiba software called “Desktop Assist”. Within this tool you would find the Toshiba HWSetup and this software part should contain the Fast boot option.

    Check it.

    By the way: for some notebook series pressing INS button and then F2 worked too.

  3. Re: Satellite Pro C50-A-1E2: Problem entering BIOS after fast boot activation
    #3
    Scholar
    Join Date
    Sep 2009
    Posts
    793
    As MisterX already wrote open “Desktop Assist” > Tools & Utilities > System settings > Boot. There you should find option called “Boot Speed”. You can change between two options – Normal and Fast.

  4. Re: Satellite Pro C50-A-1E2: Problem entering BIOS after fast boot activation
    #4
    Beginner
    Join Date
    Dec 2014
    Posts
    2
    Ok thanks for your time.Problem solved :)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •