Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 10 of 10

Thread: Satellite C50-A-1CK double characters appear when typing

  1. Satellite C50-A-1CK double characters appear when typing
    #1
    Beginner
    Join Date
    Jan 2014
    Posts
    4
    All
    I have a brand new Satellite C50-A-1CK which is perfect for my needs EXCEPT I continually get double characters appearing on screen when typing which is:
    A. VERY frustrating
    B. Wasting a lot of time as I have to keep correcting words to remove the duplicate characters.

    Please does anyone know of a fix for this? It can affect any key on the keyboard and it doesn't matter if I type slow or quick, press the keys firmly or as light as possible.

    Have checked for firmware updates but none available.

    Thanks in advance!

  2. Re: Satellite C50-A-1CK double characters appear when typing
    #2
    Beginner
    Join Date
    Jan 2014
    Posts
    2
    Hi

    I hope that someone can help you and me on this!

    I have used other machines for years, I am a reasonably competent typist but have suffered the same problem on my Satellite C850 and it drives me mad.

    Also the ease with which using the touchpad to move the cursor about results in the machine selecting the settings sidebar for Windows 8 by mistake.

    I have tried changing the keyboard sensitivity within windows but this does not seem to help - just slows the keyboard right down.

    Really frustrating

  3. Re: Satellite C50-A-1CK double characters appear when typing
    #3
    Beginner
    Join Date
    Jan 2014
    Posts
    4
    The Touchpad issue you have I mayy be able to help with....

    It sounds like you have the "Enable Edge Swipes" set on. This will bring up Windows 8 menu on the right hand side of the screen when ever you swipe from the right hand side of the keypad towards the middle.

    Yours is a different model to mine but assuming the setting is in the same place then:
    open Control Panel
    Open Hardware and Sound
    Under Devices and printers click "Mouse"
    In the "mouse properties" window click on Device Settings
    Highlight the touchpad and click the "settings" button below it
    De-select "Enable Edge Swipes"

    Hope this helps

  4. Re: Satellite C50-A-1CK double characters appear when typing
    #4
    Beginner
    Join Date
    Jan 2014
    Posts
    2
    Hi Jon_t

    Many thanks for your advice - looks like it has done the trick on the touchpad. All I need is to get over the problem on that dratted repeat keystroke problem

    Goosgog

  5. Re: Satellite C50-A-1CK double characters appear when typing
    #5
    Beginner
    Join Date
    Jan 2014
    Posts
    4
    Glad to help

    Not looking too hopeful on the double character issue :-(

  6. Re: Satellite C50-A-1CK double characters appear when typing
    #6
    From my experience the double characters issues have been solved by BIOS update.
    Therefore I would recommend you to update the BIOS (if possible)

  7. Re: Satellite C50-A-1CK double characters appear when typing
    #7
    Beginner
    Join Date
    Jan 2014
    Posts
    4
    Checked, no bios updates available for my model.

  8. Re: Satellite C50-A-1CK double characters appear when typing
    #8
    Beginner
    Join Date
    Mar 2014
    Posts
    2
    I have the same problemm and it's really annoying. My laptop is a Satellite Pro C50-A-1HQ, and I cannot even check for updates because my model is not even listed in the support webpage. It seems like I have a phantom model.

    What can I do, Toshiba!! I cannot keep going like this. If I dont find find any ssolution I will have to use the warranty and I dont wantt to cause I need my laptop.

  9. Re: Satellite C50-A-1CK double characters appear when typing
    #9
    *@Pablotron*

    >It seems like I have a phantom model.
    Satellite Pro C50-A-1HQ belongs to the PSCGBE series.
    You will find all drivers (updates) on Toshiba EU driver page choosing the Satellite Pro C50-A PSCGBE
    http://www.toshiba.eu/innovation/download_drivers_bios.jsp

    By the way: there seems to be new BIOS v1.30 released at 24/01/14
    But in case the BIOS update would not help you, you should test external USB keyboard.
    In case the external keyboard would work properly (without typing two characters in the row) there must be internal keyboard problem. In such case the internal keyboard should be replaced.

  10. Re: Satellite C50-A-1CK double characters appear when typing
    #10
    Beginner
    Join Date
    Mar 2014
    Posts
    2
    Thank you for your anwser. I have updated the bios and the problem is *90% solved.*
    Still have some double characters, but from time to time.

    Before the updated it was once every 4 or 5 words.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •