Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 4 of 4

Thread: Qosmio G10 - continuous beep on start up

  1. Qosmio G10 - continuous beep on start up
    #1
    Beginner
    Join Date
    Sep 2005
    Posts
    1
    Hi,

    I have a Qosmio G10. It's worked fine up until recently. Now when I start it up, I hear a continuous beep. There is also no screen image.

    Can anyone help?

    Many thanks

    Martin

  2. Re: Qosmio - continuous beep on start up
    #2
    Beginner
    Join Date
    Sep 2005
    Posts
    14
    I think there is a problem in the hardware configuration.
    Did the laptop receive a shock recently?
    The laptop beeps because the checks of the bios detected an anomaly.
    What you can easily do is to check that at least the RAM is correctly inserted in its place. It happened to me once: I did not inserted correctly the additional RAM that I added, and the laptop beeped loudly!
    If it does not solve the problem=> toshiba service.


    Message was edited by: djfizz2

  3. Re: Qosmio - continuous beep on start up
    #3
    Beginner
    Join Date
    Oct 2005
    Posts
    1
    Hi Martin
    Have you resolved your problem,
    I have the same with my G10,have removed battery,memory and hard drive but still the same, will not boot from cd drive just gives a blank screen and continuous high pitched whine.
    regards Jim

  4. Re: Qosmio - continuous beep on start up
    #4
    Master
    Join Date
    Feb 2005
    Posts
    2,370
    Hello

    I agree with dfj… If you didn’t exchange some hardware components or even added a new one there must be some hardware problem and you should contact technicians.

    Bye

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •