Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 4 of 4

Thread: Satelite L300D- Black screen at start-up

  1. Satelite L300D- Black screen at start-up
    #1
    Beginner
    Join Date
    Aug 2012
    Posts
    3
    Hi People,

    Any help would be greatly appreciated.

    I have a Toshiba Satelite L300D-11V. I dont know what happens but now when ever I try to power on I just get a black screen, a power light and NO HDD activity.

    From what I have read I suspect I need to flash the Bios, but I seem to be struggling with this.

    Anybody sucesfully flashed? Any tips??

  2. Re: Satelite L300D- Black screen at start-up
    #2
    Master
    Join Date
    Sep 2009
    Posts
    2,031
    For me it sounds like screwed up BIOS?
    Have you tried to update BIOS last days?

  3. Re: Satelite L300D- Black screen at start-up
    #3
    Beginner
    Join Date
    Aug 2012
    Posts
    3
    Yes I thinking same too.

    Any ideas how to flash the BIOS whenit does not show any signs of life after switch on???

  4. Re: Satelite L300D- Black screen at start-up
    #4
    Beginner
    Join Date
    Sep 2012
    Posts
    1
    i have a similar issue with Sat lite L500. When i turn on the laptop complete screen back.
    *i fixed the problem like this.*

    Removed the battery. Press and hold the Power button for more than 30 sec. and used an ac adapter to turn on the laptop.It really worked for me.

    Now it is booting without any problem.i don't know if the same will work on other models.
    If this not working you can try the same procedure with battery inserted.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •