Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 4 of 4

Thread: Satellite C660-173 is not booting at all

  1. Satellite C660-173 is not booting at all
    #1
    Beginner
    Join Date
    Aug 2012
    Posts
    2
    Hi

    I have a Satellite C660-173, the laptop was running fine as of yesterday but today I tried to boot the machine and the screen is totally black,I can hear the fan running and then after say 30 secs it turns off.

    Have removed the battery and held down the power button for 30 secs and reconnected everything with the same result, does any one know what the issue could be?

    Thanks

  2. Re: Satellite C660-173 is not booting at all
    #2
    Beginner
    Join Date
    Jun 2012
    Posts
    62
    Hi,

    you can try to connect on a external screen, If your screen is still black then i think your defice have a defect.

    give me feedback.

  3. Re: Satellite C660-173 is not booting at all
    #3
    >... screen is totally black, can hear the fan running and then after say 30 secs it turns off.
    It sounds pretty bad and for me definitely as corrupt BIOS. Have you maybe updated BIOS or done anything that can be responsible for this?

  4. Re: Satellite C660-173 is not booting at all
    #4
    Beginner
    Join Date
    Aug 2012
    Posts
    2
    yes i did update the bios to the latest version that is available on the website

    is this an update issue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •