Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 20 of 20

Thread: Re: Satellite L300 - Unknown devices in device manager

  1. Satellite L300 - Unknown devices in device manager
    #1
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    Hi,

    satellite L300 OS - Vista 32

    I installed new software to use USB port to connect the board and program that board During this installation some things went wrong and all my USB port are not responding or not working at all...

    When i checked the Device Manager it shows like Other device -> Unknown device..

    I install the chipset from Toshiba download and still I can’t solve the prob....

    my USB all port not working..
    my WiFi is not working..
    my Camera is not working...

    rest of all work i guess any suggestion to solve this problem?

  2. Re: Satellite L300 - Unknown devices in device manager
    #2
    Master
    Join Date
    Jun 2009
    Location
    Italy
    Posts
    3,875
    Hi

    Could it be possible that the 3rd party software which you have installed to use the USB ports has muddled up the whole system?

    The driver for the unknown device which appear in the device manager can be identified very easily.

    I recommend checking this HowTo:
    http://forums.computers.toshiba-europe.com/forums/ann.jspa?annID=78

    You need the Vendor ID and Device ID and using these both ID in pci database would help you to find out the right driver.

    By the way: if your Wlan and cam don’t work, install the drivers… die you already tried this?

  3. Re: Satellite L300 - Unknown devices in device manager
    #3
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    Hi,

    Thanks for your reply...

    i try to install the driver from intel and it doesn't install it will get error and stop installing when i uninstall this Unknown Device from Device Manager then the intel chip set install then after installing full then again it will show the same Unknown device...

    yes i install the camera driver it say error occurred while installing then it will exit the set up..

    for WLAN it install but when i switch on my WiFi it doesn't discover any device so it also not working fully..

  4. Re: Satellite L300 - Unknown devices in device manager
    #4
    Master
    Join Date
    Jun 2009
    Location
    Italy
    Posts
    3,875
    Would recommend uninstalling the software firstly which muddled up the OS.
    Then clean the registry using CCLeaner and then check the ven and dev id as mentioned in the HowTo.

    What L300-xxx do you have exactly?

  5. Re: Satellite L300 - Unknown devices in device manager
    #5
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    hi,

    L300-110 SYSTEM UNIT
    Model No: PSLB0E

    yes i uninstall that software and i clean the registry and install the chip set and have same prob yet...

  6. Re: Satellite L300 - Unknown devices in device manager
    #6
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    when system try to find it self it show the following error message:

    windows found driver for your device but encounter an problem while attempting to install it..

    inter(R) ICH8 family USB Universal Host Controller 2834

    an error occur during installing of the driver

    The driver installing file for this device is missing a necessary entry. this may be bcz of INF was written for win95 or old.. ..

    so i try to install the chip set from intel and also from Toshiba but no result....

  7. Re: Satellite L300 - Unknown devices in device manager
    #7
    Master
    Join Date
    Jun 2009
    Location
    Italy
    Posts
    3,875
    Found the detailed specifications of this unit:
    Chipset: Mobile Intel® GL960 Express Chipset
    WLan: Realtek 802.11g (RTL8187B)

    The error seems to appear because there is an driver on the system which is not compatible with Vista.
    As said the software you installed, has replaced the vista driver with an Win 95 driver or similar… I think you should make a cut here.
    Use the system restore tool provided with the Vista and set the system back to the time point before the software has been installed.

  8. Re: Satellite L300 - Unknown devices in device manager
    #8
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    i try to restore my system but i have install lot of driver after that so i could find the old restore point before i install that software as it have only few number of restore so i cont do that also now... what can i do now more?

  9. Re: Satellite L300 - Unknown devices in device manager
    #9
    Master
    Join Date
    Jun 2009
    Location
    Italy
    Posts
    3,875
    Hmm… that’s bad news…
    The point is that the name of the ini file is not known to me and I assume you don’t know the name too… in such case it’s difficult to remove this from the system.
    As last resort you can try recover the system using recover disk but not sure if its really a option for you…

  10. Re: Satellite L300 - Unknown devices in device manager
    #10
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    thank you for your reply....

    i dont have recovery disk or i have not made any recovery that is prob also for me now...any other option?

    is it possible to repair my vista... i have Vista OS in D: drive...is it?

  11. Re: Satellite L300 - Unknown devices in device manager
    #11
    Master
    Join Date
    Jun 2009
    Location
    Italy
    Posts
    3,875
    Do you mean you have got the HDD recovery image on the second partition?
    If yes, then you can use the HDD recovery as mentioned here.

    +How to recover a Toshiba notebook with the HDD recovery procedure+
    http://aps2.toshiba-tro.de/kb0/HTD1303440001R02.htm

  12. Re: Satellite L300 - Unknown devices in device manager
    #12
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    yes i have HDD recovery but in that folder or file is Date modify is 2008 so i dont think it will have new vista or new OS for my laptop now.....

    or its possible to repair by visa CD by inserting vista CD?

  13. Re: Satellite L300 - Unknown devices in device manager
    #13
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    i install new OS after that may be i think what i have in other partition is old OS recover i guess...

  14. Re: Satellite L300 - Unknown devices in device manager
    #14
    > or its possible to repair by visa CD by inserting vista CD?

    You can use the Vista disk in order to repair the system too.
    Boot from Vista DVD. An Windows Vista screen should appear where you could choose a option: Repair my Computer. This appears at the bottom of the line “what to know before installing Windows”.

  15. Re: Satellite L300 - Unknown devices in device manager
    #15
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    thank you for reply i will try this way... let me see how it works....

    any other way to solve this problem?

  16. Re: Satellite L300 - Unknown devices in device manager
    #16
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    can any one still help me with some other way with out repair or installing vista?

  17. Re: Satellite L300 - Unknown devices in device manager
    #17
    Beginner
    Join Date
    Apr 2012
    Posts
    1
    Hello,

    I had the same problem with my Toshiba laptop , and i finally found the drivers by using DriverIdentifier, it will scan your device and give you a list of available drivers for your laptops.

    I hope it help.

  18. Re: Satellite L300 - Unknown devices in device manager
    #18
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    Thanks.... i know the device specification by its *vendor and device* and i try to download the specific device driver and install the driver but it abort the installation or if i uninstall this *Unknown device* from device manager and install that new driver it *install successfully* but when i scan for hardware change or restart my system it show the error *Unknown device or system detect the drive for ur device but problem in installing the new drive*.... then it will show like unknown device in device manager

    any solution?

  19. Re: Satellite L300 - Unknown devices in device manager
    #19
    Master
    Join Date
    Sep 2009
    Location
    Italy
    Posts
    3,816
    *>venkat09*
    I see that many workarounds have been posted here and no one was able to resolve this… I think the users here are right: looks like the system issue.
    Before waiting days and searching for other possible solutions, why you don’t try the recovery disk…of course it’s painful to back up the data before doing this but it looks like it would be the fastest solution.

  20. Re: Satellite L300 - Unknown devices in device manager
    #20
    Beginner
    Join Date
    Apr 2012
    Posts
    12
    thanks for ur reply...i dont like to disturb my OS as it dont have any prob for long time...... it seem like some of the drive what i installed have prob in incompatibility issue.... with intel and Toshiba and Windows any one of this have prob so i think i can wait till one of this company will come with good solution soon.... and update the software......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •