Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 3 of 3

Thread: Re: USB Ports are not working on old Satellite P10 (PSP10E)

  1. USB Ports are not working on old Satellite P10 (PSP10E)
    #1
    Beginner
    Join Date
    Mar 2012
    Posts
    1
    Have searched the forum and noted that this has happened a few times but doesn't really say what happened.

    I have updated the bios with the bios from this website 2000a.rom. The USB ports have power, as they can charge a usb bike light, but not seen under windows or under several versions of Linux.

    The only other thing that has been mentioned is a new motherboard which is not an option with this laptop as its is quite old, i would like to keep it going as it is a good little laptop

    Thank you for your help.

  2. Re: USB Ports are not working on old Satellite P10 (PSP10E)
    #2
    Master
    Join Date
    Dec 2004
    Posts
    1,807
    Do you have original WXP recovery disc for this old Satellite notebook?

  3. Re: USB Ports are not working on old Satellite P10 (PSP10E)
    #3
    Master
    Join Date
    Sep 2009
    Location
    Italy
    Posts
    3,826
    Hi

    USB controllers are not recognized by Windows OS?
    Well, did you notice this before updating the BIOS?
    Did you test the USB ports using new, fresh preinstalled OS?

    Fact is that Win XP should recognize the USB ports automatically… even if the drivers would not be installed, the USB controllers should appear as unknown device or marked with an yellow exclamation mark…

    If this is not the case, well… sounds like hardware issue…

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •