Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 3 of 3

Thread: Ethernet Controller is not working on Satellite L645D-S4030

  1. Ethernet Controller is not working on Satellite L645D-S4030
    #1
    Beginner
    Join Date
    Jun 2011
    Posts
    1
    Basically i got my windows 7 reinstalled on to my laptop because of viruses......Now I have a issue with the Ethernet controller not working, I checked my device manager and there's some kind of yellow dash across the icon......Anyone know what the problem is and how i can fix this problem ????

    BTW i have a SATELLITE L645D-S4030

  2. Re: Ethernet Controller is not working on Satellite L645D-S4030
    #2
    Scholar
    Join Date
    Sep 2009
    Posts
    793
    Have you reinstalled OS using original Toshiba recovery image (preinstalled Win7) or you ave installed OS on your own?

    Anyway, visit Toshiba download page and try to reinstall offered LAN driver from there.

  3. Re: Ethernet Controller is not working on Satellite L645D-S4030
    #3
    Master
    Join Date
    Oct 2009
    Posts
    1,740
    Hi buddy,

    Hmm… Usually if you reinstall Windows from Toshiba recovery disk all drivers will be installed too because the disk contains an image of factory settings.
    Or have you used another disk?

    Yellow exclamation mark could mean there is a driver issue so it would be recommendable reinstalling the LAN driver. Follow the link posted Timox. After installing the driver restart your computer and check device manager again. Normally the yellow exclamation mark should be vanished.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •