Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 4 of 4

Thread: Satellite Pro L550-13M - Screen turns off several times

  1. Satellite Pro L550-13M - Screen turns off several times
    #1
    Beginner
    Join Date
    Jun 2011
    Posts
    1
    Hi,

    Strangely the above laptop has repeatedly turned its screen off several times.The lights are all on, but the screen goes completely dead. On restart the screen is okay, for about 10 minutes then it goes blank again! We've restarted it a few times and its done it again and again. I've booted it up in safe mode and checked the latest AV updates etc, which are up to date. There haven't been any recent software additions.
    We're now backing things up just in case!

    Can anyone help with what this might be?

    Thanks!

  2. Re: Satellite Pro L550-13M
    #2
    Akuma
    Guest
    When the screen turns off, is Windows still running in the background? For example if you press the power button, do you see HDD activity?

    What devices do you have attached when it happens?

    Have you attach an external monitor, does the external screen blank out as well?

  3. Re: Satellite Pro L550-13M - Screen turns off several times
    #3
    Master
    Join Date
    Oct 2009
    Posts
    3,014
    Hi guineverestar,

    Easiest way to check this problem is connecting an external monitor. If you notice the same behavior on external monitor it seems to be a problem of software or internal hardware. Otherwise itís just the internal monitor that is malfunctioning.

    Check this!!!

  4. Re: Satellite Pro L550-13M - Screen turns off several times
    #4
    Beginner
    Join Date
    Jun 2011
    Posts
    1
    Hiya

    Not 100% sure if you have the same setup as the laptop I have, but this happened to me on several occasions and I thought it was a screen burnout or a software problem despite the fact that I'd only had the laptop for 5 days.

    I managed to resolve it, but had to connect to an external monitor to do so. When I right clicked on the desktop a menu appears with a tab called graphic options. Click on this then choose output tools / clone displays / built in display + monitor. This should resolve your problemo.

    Good luck!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •