Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 7 of 7

Thread: Portege R100 - Blank screen on boot

  1. Portege R100 - Blank screen on boot
    #1
    Beginner
    Join Date
    Mar 2011
    Posts
    3
    Hi, hope someone can guide me in the right direction

    I have a Protege R100 notebook.

    When I start it up the power light comes on and the display briefly flashes into action but then stays black. The drive still works and loads the OS, but I cannot get the screen to display anything.

    Thanks

  2. Re: Portege R100 - Blank screen on boot
    #2
    Master
    Join Date
    Oct 2009
    Posts
    3,014
    Hi JFarr29,

    That means you can see a picture on an external monitor and only the internal monitor isn’t working properly, right?

    Well, in this case it could be the FL inverter or display itself… This should be checked from an authorized service provider if you are not familiar with notebook disassembling.
    Do you know how to contact the guys?

  3. Re: Portege R100 - Blank screen on boot
    #3
    Master
    Join Date
    Sep 2009
    Posts
    2,181
    It is not easy to offer exact answer. It can be display cable and connection on display’s side, maybe FL inverter or display itself.
    It must be investigated and notebook disassembled.

    Can you do this on your own?

  4. Re: Portege R100 - Blank screen on boot
    #4
    Beginner
    Join Date
    Mar 2011
    Posts
    3
    Thanks folks.
    Yes I can do repairs myself. I have already tried replacing the screen invertor and my next step would have been
    the backlight unless you think otherwise - I was hoping it was a common issue.

    The screen isn't actually totally black, it is extremely faint and hence does work externally on a monitor.

  5. Re: Portege R100 - Blank screen on boot
    #5
    Master
    Join Date
    Sep 2009
    Posts
    1,242
    I cannot say for sure but I think it must be FL inverter.
    Check Google and you can order it online. For instance – here .

  6. Re: Portege R100 - Blank screen on boot
    #6
    Beginner
    Join Date
    Mar 2011
    Posts
    3
    Yeah, thats what I thought, but have just stuck a new one in and its the same issue. Really dim from boot
    Could it be backlight or I am just throwing good money after bad???

  7. Re: Portege R100 - Blank screen on boot
    #7
    > The screen isn't actually totally black, it is extremely faint and hence does work externally on a monitor
    I think it’s a FL inverter too… The faint display is a typical issue for a faulty FL inverter.
    I think you can order a new FL inverter from Toshiba Authorized service partner in your country…. Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •