Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 5 of 5

Thread: Satellite C660-108 - Fan keeps running

  1. Satellite C660-108 - Fan keeps running
    #1
    Beginner
    Join Date
    Feb 2011
    Posts
    1
    I just bought a Satellite C660-108 and the fun keeps running all the time. Is it normal?

  2. Re: Satellite C660-108 - Fan keeps running
    #2
    Master
    Join Date
    Oct 2009
    Posts
    1,740
    Hi Judith_2,

    If your notebook is in idle-mode it isn’t normal that the fan is always running. Normally it should start/stop as on other models.
    But if you run some background applications like Internet Browser, Antivirus, etc. it might be normal because the CPU causes a lot of heat and it must be cooled to protect it from hardware damages.

    Anyway, you can try to change the cooling method in Windows Power Management. You can choose between “Maximum Performance” and “Battery Optimized”. If you want to reduce it, change the latter value.
    I can confirm there is really a difference between the cooling methods and Battery Optimized is much quieter.

  3. Re: Satellite C660-108 - Fan keeps running
    #3
    Beginner
    Join Date
    May 2011
    Posts
    2
    HI, i also bought a satelite c660 1j2 and the fun goes on and off every 30 sec for about 10 sec .
    My laptop i keeped in a clean atmosfer on clean surface.

  4. Re: Satellite C660-108 - Fan keeps running
    #4
    Master
    Join Date
    Sep 2009
    Posts
    2,030
    Change “Cooling method” settings and I hope it will help you.

    Open advanced power settings for power plan that you use and there you will find it.
    This should reduce cooling fan activity.

  5. Re: Satellite C660-108 - Fan keeps running
    #5
    Beginner
    Join Date
    May 2011
    Posts
    2
    thanks As***

    i allready change these settings several times to optimal and then again to prestation modes .
    I also have download some software from the net like speedfun,cpuid hwmonitor-cpuz, core temp, GPU-Z.0.5.3
    but the problem remains
    the only thing that has left to do is to bring it back to his originly state or any other sugestions?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •