Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 14 of 14

Thread: HDMI not working on Satellite L500-19Z

  1. HDMI not working on Satellite L500-19Z
    #1
    Beginner
    Join Date
    Jun 2010
    Posts
    18
    I have an L500-19Z running Windows 7. Up until yesterday the HDMI output socket was working fine.
    However, now, when I plug a cable in the screen keeps goes blank and then returning to normal.
    This continues for a few minutes and then when I try to output to eg a TV it shows as not connected.

    Does anyone have any thoughts on what might be causing this?
    Device Manager says that the device is working OK and I've checked that the driver is up to date.

    I'm now stumped!
    Any replies can also be directed to a.nicholles@ntlworld.com

  2. Re: HDMI not working on Satellite L500-19Z
    #2
    Hi

    Did you try the Fn + F5 option?
    This switch the video output to external monitor or TV.
    You have to press this several times in order to choose TV.

    Set also BIOS to default settings and test it again

  3. Re: HDMI not working on Satellite L500-19Z
    #3
    Beginner
    Join Date
    Jun 2010
    Posts
    18
    Thanks but the Fn F5 option seems not to have any effect. Do you know how to set the BIOS back to default settings?

  4. Re: HDMI not working on Satellite L500-19Z
    #4
    Hi

    To set BIOS to default you have to access the BIOS (press F2 while booting).
    In BIOS you have to press F9 (I guess but at the bottom of the BIOS page you can find the description what button is needed).
    Save the changes and reboot again.

    If FN buttons does not work, then you should reinstall the VAP and Flash Card Utility again.
    Also the display driver update might be useful.

  5. Re: HDMI not working on Satellite L500-19Z
    #5
    Beginner
    Join Date
    Jun 2010
    Posts
    18
    No, it's still not working. The Fn F5 is now working OK but switching to HDMI, or extended mode, still doesn't solve the problem. I'm beginning to suspect that it's a hardware fault. Do you agree?

  6. Re: HDMI not working on Satellite L500-19Z
    #6
    Donít think itís hardware issue.
    Reinstall the display driver and check it again.
    Otherwise you will need to test it with new clean OS.

  7. Re: HDMI not working on Satellite L500-19Z
    #7
    Beginner
    Join Date
    Jun 2010
    Posts
    18
    Sorry for delay - been out all day. When I open Device Manager which item contains the 'display driver'? Is it the sound, video controller which contains the HDMI line?

  8. Re: HDMI not working on Satellite L500-19Z
    #8
    Master
    Join Date
    Sep 2009
    Posts
    1,008
    Hey,

    The display driver belongs to graphic card.

    As MasterG wrote you should reinstall it. You can check the Toshiba page yourself for an update:
    http://eu.computers.toshiba-europe.com > Support & Downloads

    After download it, remove the old display driver from control panel > Uninstall software. Then restart your computer and install newest display driver.

  9. Re: HDMI not working on Satellite L500-19Z
    #9
    Beginner
    Join Date
    Jun 2010
    Posts
    18
    No, I tried that and it caused all sorts of problems. Windows failed to load and eventually I had to let Windows 'repair' itself and then I could run a system again.

  10. Re: HDMI not working on Satellite L500-19Z
    #10
    Master
    Join Date
    Oct 2009
    Posts
    1,927
    Hello

    Hmm... It seems that something is wrong with your Windows installation because the Toshiba drivers are pretested and from my own experience I can say that I never had any problems with these drivers.

    As MasterG already wrote you should reinstall Windows from Toshiba recovery disk to test it with preinstalled software and drivers.

    Check this!!!

  11. Re: HDMI not working on Satellite L500-19Z
    #11
    Beginner
    Join Date
    Jun 2010
    Posts
    18
    OK, will that mean reformatting my hard drive with a subsequent loss of data? If so, I'll make sure everything's backed up before doing it.

    The other thing I've noticed is that I can't use System Restore. Whenever I try to restore, it fails no matter which restore point I choose.

  12. Re: HDMI not working on Satellite L500-19Z
    #12
    Master
    Join Date
    Oct 2009
    Posts
    1,927
    Hello

    If you use the Toshiba recovery disk for reinstalling Windows it will delete the whole HDD so you have to backup all important data on an external HDD for example.

  13. Re: HDMI not working on Satellite L500-19Z
    #13
    Beginner
    Join Date
    Jun 2010
    Posts
    18
    Since we last spoke I've had to re-install Windows because of another problem I had but it hasn't resolved the HDMI issue. I suppose it's possible that it may be a TV fault but as my laptop screen flashes on, and off, when the cable is inserted I'm inclined to believe that it's still a laptop issue. I can only think that it must be some kind of hardware issue.

  14. Re: HDMI not working on Satellite L500-19Z
    #14
    To be honest I have no idea why this is not working in your caseÖ. In my case the procedure was very easy; connect TV and notebook with an good quality HDMI cable.
    Choose the right channel on TV which belongs to the HDMI port of the TV.
    Then power up the notebook. After that use FN + FN 5 in order to switch to external output. Note; you will need to press this several times to get HDMI as video output.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •