Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 8 of 8

Thread: Satellite A660-10W - After Windows 7 installation some unknown devices

  1. Satellite A660-10W - After Windows 7 installation some unknown devices
    #1
    Beginner
    Join Date
    Aug 2010
    Posts
    4
    So I have the Satellite A660-10W, and I reinstalled the Windows 7 it came with Windows 7 ultimate 64bit. First thing is when I use fn+F6/F7 (other combinations work) for brightness levels it doesn`t work, brightness doesn`t change. And the other thing is that there seem to be some unknown devices.

    Here is everything hope someone can think of what could it be, thanks in advance. :)
    Link: [http://store.picbg.net/pubpic/B4/3E/3ca598fbde5fb43e.png]

  2. Re: Reinstalled Win7, some things not working
    #2
    Master
    Join Date
    Mar 2010
    Posts
    2,584
    You should try to install: Bluetooth, Infrared, Modem drivers....

    http://eu.computers.toshiba-europe.com/innovation/download_drivers_bios.jsp

    Anyway, it will be better if you post vendor/device's id:

    http://forums.computers.toshiba-europe.com/forums/ann.jspa?annID=78

  3. Re: Satellite A660-10W - After Windows 7 installation some unknown devices
    #3
    Master
    Join Date
    Oct 2009
    Posts
    3,013
    Hi ihatethis,

    Everything what you need can be downloaded on official Toshiba European page:
    http://eu.computers.toshiba-europe.com > Support & Downloads > Download Drivers

    But I donít understand why you have Windows 7 on this new notebook.
    And if you install Windows 7, take Toshiba recovery disk with all drivers and tools. Itís a pretested image.

    For FN keys you need Toshiba tools like Value Added Package and Flash Cards Support Utility.

  4. Re: Satellite A660-10W - After Windows 7 installation some unknown devices
    #4
    Beginner
    Join Date
    Aug 2010
    Posts
    4
    Funny thing the unknown device turned out to be the bluetooth.

    @Xardas What do you mean, why do I have Windows 7, i bought the notebook with it installed, set up and all like yesterday, but there were some things I did not like and decided to install ultimate version. The Fn keys work, when I push it top on the screen are shown the buttons, I mean I have the TOSHIBA Accessibility, but the brightness leveling just doesn`t work.

    Anyway thank you both.

    Message was edited by: ihatethis

  5. Re: Satellite A660-10W - After Windows 7 installation some unknown devices
    #5
    Master
    Join Date
    Sep 2009
    Posts
    1,248
    Hey,

    If brightness leveling doesnít work, make sure that Value Added Package and Flash Cards Support Utility are installed.

    You can download it on official Toshiba page. Follow the link posted by Xardas. :)

  6. Re: Satellite A660-10W - After Windows 7 installation some unknown devices
    #6
    Beginner
    Join Date
    Aug 2010
    Posts
    4
    Yes they both are installed, still doesn`t work? Even in Control Panel`s PowerSettings the brightness leveling doesn`t work.

  7. Re: Satellite A660-10W - After Windows 7 installation some unknown devices
    #7
    Have you installed display driver?
    As far as I know brightness settings in power management will be available and work when proper display driver is installed.
    > i bought the notebook with it installed, set up and all like yesterday, but there were some things I did not like and decided to install ultimate version.
    Yes and now you fight with OS configuration. Good luck!
    Better option is to remove all preinstalled stuff you don't need and still have perfect configured OS. Have you created recovery DVD before you have installed own Win7 version?

  8. Re: Satellite A660-10W - After Windows 7 installation some unknown devices
    #8
    Beginner
    Join Date
    Aug 2010
    Posts
    4
    OK you and my friend are right, because I installed the video card drivers from nvidia`s website, not from toshiba, now brightness works :D
    And I reinstalled Windows because one thing there were no partitions only one lonely drive and I wanted 30-40gigs for windows and the rest for stuff, not when I decide do reinstall lets say a year later with work and media on it to lose everything. I didn`t do any back ups, even all the shop assistant talked about when I bought it was to buy some dvd`s and backup, but I said I never did that before so why would I need it now, anyway now everything works perfectly, iI`m prepared for the next time :D , thanks for the help. :)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •