Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 3 of 3

Thread: Satellite Pro M60-164 doesn't power up at all

  1. Satellite Pro M60-164 doesn't power up at all
    #1
    Beginner
    Join Date
    Jun 2010
    Posts
    1
    Hi,

    Ive got a Sat Pro and when i plug it in the mains the light on the charger comes on but the laptop doesn't power up at all.
    If i take the battery out the laptop and plug it into the mains, its still dead.

    Any help, greatly appreciated.
    Danny

  2. Re: Satellite Pro M60-164 doesn't power up at all
    #2
    Master
    Join Date
    Jun 2009
    Location
    Italy
    Posts
    3,908
    Hi

    It seams that this has nothing to do with power mains but with an internal hardware problem on the mobo.
    I think you should firstly check the both memory modules inside the notebook.
    If the notebook would not power up even using new modules, then other parts like CPU or motherboard should be checked.

    Sorry but this is everything what I could suggest you.

  3. Re: Satellite Pro M60-164 doesn't power up at all
    #3
    Akuma
    Guest
    I agree with Paolo, it seems to be a Mainboard problem. Send the notebook to an ASP for repair/quotation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •