Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 10 of 10

Thread: Re: Tecra M5 PTM51E - CPU upgrade issue

  1. Tecra M5 PTM51E - CPU upgrade issue
    #1
    Beginner
    Join Date
    Dec 2009
    Posts
    3
    Hi, I have Tecra M5 PTM51E model with T2600 Yonah (2.16ghz,667fsb) core duo processor, few days ago I just replaced this cpu with core 2 duo - T7400 Merom (2.16ghz, fsb667) and all works almost fine... cpu is properly recognized, I was able to install win7 64bits.

    The only problem i have is fan speed, it is going full speed from booting laptop till shutdown, i have latest BIOS 3.70, Toshiba Power Saver - no matter what i set fan is going 100% speed, temperatures are ok, HWmonitor shows 28-30C in idle and 60 in stress, and fan was cleaned during cpu replacement.

    I assume i need toshiba diagnostic/maintenance cd to set proper values for fan speed to this processor?

    I appreciate any suggestions, thanks!

  2. Re: Tecra M5 PTM51E - CPU upgrade issue
    #2
    Akuma
    Guest
    I tried upgrading the CPU in my laptop and ran into the same problem.

    If the BIOS doesn't support the CPU model, then the CPU speed and fan speed will be incorrect.

    You will need to use one of the CPU's that are available in the Tecra M5 range for the calibration to work properly.

  3. Re: Tecra M5 PTM51E - CPU upgrade issue
    #3
    Beginner
    Join Date
    Dec 2009
    Posts
    3
    Please note that BIOS 1.70 supports Merom CPUs, so version 3.70 for sure, even more there are M5 with T7400 or T5600 orginally mounted by Toshiba.
    Even more energy saving works ok with this T7400, cpu is downclock in idle to 1ghz, cpuz properly shows all cpu details, only this fan works improperly.

    Do you know if Toshiba diagnostic/maintenance disc can help with this isuue?

  4. Re: Tecra M5 PTM51E - CPU upgrade issue
    #4
    Akuma
    Guest
    I think only Toshiba's Authorized Service Providers have access to those kind of tools.

    There is a list of ASP's on the Toshiba site, maybe they can do it for you.

  5. Re: Tecra M5 PTM51E - CPU upgrade issue
    #5
    Beginner
    Join Date
    Dec 2009
    Posts
    3
    ok, in this situation Toshiba toolscd are needed, cpu/dmi update must be done to laptop, after this works perfectly!!!

  6. Re: Tecra M5 PTM51E - CPU upgrade issue
    #6
    Beginner
    Join Date
    Sep 2010
    Posts
    3
    I have the same problem. It's good to know it can be made to work but we could do with some more details on how you achieved it; which Toshiba Tools cd is needed? Where can we download it? Is there a specific program we need to run to update the cpu\dmi information? Could you write a short guide on how to do it?

  7. Re: Tecra M5 PTM51E - CPU upgrade issue
    #7
    Beginner
    Join Date
    Jul 2011
    Posts
    1
    dgeddon, are you still hunting to fix this?

  8. Re: Tecra M5 PTM51E - CPU upgrade issue
    #8
    Beginner
    Join Date
    Sep 2011
    Posts
    2
    I am hunting for a fix to this, I have a Tecra M9 which I upgraded the CPU. It works fine apart from the CPU fan constantly runs at 100% I updated my BIOS from ver 1.4 to V2.0 downloaded from the toshiba website but that hasnt changed anything. Fan still runs at 100% although the compujter rexognises and utilises the new CPU, been monitoring temps for a week now and they are fine

  9. Re: Tecra M5 PTM51E - CPU upgrade issue
    #9
    Master
    Join Date
    Sep 2009
    Location
    Italy
    Posts
    3,817
    > I upgraded the CPU. It works fine apart from the CPU fan constantly runs at 100%

    You have installed a stronger CPU which is faster and produces more heat dissipations.
    Itís nothing unusual that your fan runs faster.
    The cooling module has to run faster to ensure that CPU would be cooled properly.

  10. Re: Tecra M5 PTM51E - CPU upgrade issue
    #10
    Beginner
    Join Date
    Sep 2011
    Posts
    2
    Success, sorry to revive an old thread but I had given up on finding a fix for this problem ages ago and decided to just live with this noisy fan but as I have just bought a new battery for this laptop its prompted me to re-visit this issue once more.

    Thanks to the information found at http://forums.overclockers.com.au/showthread.php?p=13377667

    I have found the elusive diagnostics boot disk.
    Had some issues extracting the tools as I didn't have an external floppy drive but a floppy drive emulator and using a HP tool to make a usb drive bootable helped.

    On extracting the boot disk you get a dialog box as follows

    Test and Diagnostics v1.50
    Option 2, "Repair initial config set", must be run whenever the CPU or the system board is replaced
    Use a 1.44MB disk to extract the disk image

    which is the first inkling that this might be the real fix and sure enough on booting from the flash drive you run 2.bat file and choose option 1 to run the initial configuration.

    After the magic runs Laptop will turn off and voila - A normal quiet stable lovely fan noise - very happy to finally found a fix

    Oh and link to the download file is http://download.toshiba.com/tem91t1.exe

    Awesome!! :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •