Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Problem charging Camileo S10

  1. Problem charging Camileo S10
    #1
    Beginner
    Join Date
    Dec 2009
    Posts
    1
    Hi all Toshiba users!!

    I've just bought a Camileo S10 camera, and it looks apretty nice, small and light. But it doesn't seem to charge the battery, neither power on. Here's how I've proceeded:

    1) I removed the insulant from the battery, and put it again, closing the case.
    2) I plugged it in with its own charger, which uses the USB connector.
    3) Circle LED around the "Record" button lights on (but doesnt blink as stated in manual).
    4) When 5 minutes pass, the LED powers off and never lights on again.

    Is this normal behaviour? Because when I try to power on the camera, it just does nothing. I tried flipping the LCD screen and also tried with power button, with USB charger disconnected. Camera doesnt react at all. When I power on with charger connected it works correctly.

    Thanks for your help!

    Message was edited by: m0sk4

  2. Re: Problem charging Camileo S10
    #2
    Hi

    The new battery is completely empty!
    Therefore you should leave the battery connected to the power for a longer time.

    Furthermore computer will not charge the battery when connected. You must use ONLY the supplied AC charger! Camcorder must be turned OFF; blinking light confirms charging but light is constant when charging has been completed!

  3. Re: Problem charging Camileo S10
    #3
    Beginner
    Join Date
    Mar 2010
    Posts
    1
    What happens if you use a different charger - ie a BlackBerry charger for the same voltage?

  4. Re: Problem charging Camileo S10
    #4
    Beginner
    Join Date
    May 2010
    Posts
    2
    *I have the EXACT same problem, battery won't charge.*
    *Camera only works when connected to charger.*

    _+*Light doesn't flash when charging as stated in manual*+_, just lights up constant for a while then goes out.

    This is very strange, a completely new camera and it doesn't even work.

    And don't tell me anything about that it has to charge for like a week, an hour should be sufficiant to at least start it up and see if it works, which it doesn't.

  5. Re: Problem charging Camileo S10
    #5
    Beginner
    Join Date
    May 2010
    Posts
    2
    The light doesn't blink when connected to charger as it should, indicating that battery is charging, only constant light and then goes out.
    Didn't you read his post?

  6. Re: Problem charging Camileo S10
    #6
    Master
    Join Date
    Sep 2009
    Posts
    3,783
    I’ve got another Camielo camcorder.
    The battery didn’t charge even if the camcorder was connected to the AC adaptor a whole night long…
    I though the battery is dead… I disconnected everything and left the camcorder for week or two… Then I tested it again… connected a AC to camcorder and guest what; the battery started to charge and everything was ok again…
    I have no idea what happened but it worked then…

  7. Re: Problem charging Camileo S10
    #7
    Beginner
    Join Date
    Jun 2010
    Posts
    1
    just been given a camileo, brand new in sealed box. It doesn't turn on. I have tried charging it and nothing, no lights, still no activity at all. Connected it to my PC and still nothing. Yes the battery is in. I've tried it with and without SD. I've taken the battery out and put it back afetr 10 minutes.
    If this is Toshiba quality, I'm not impressed.

  8. Re: Problem charging Camileo S10
    #8
    Master
    Join Date
    Sep 2009
    Posts
    2,150
    Hi zadave

    Contact your local dealer and ask for exchange. I am 100% sure you will get other one.

  9. Re: Problem charging Camileo S10
    #9
    Beginner
    Join Date
    Jul 2010
    Posts
    1
    im going away tomorrow and i've lost the charger for my toshiba camileo s10. However i have the usb cable, connected it to my laptop and its not charging, just a constant red light? Then i aslo tried plugging it into my ipod charger and then into a wall plug, but still the same thing. Will it literally not charge without the proper charger?

  10. Re: Problem charging Camileo S10
    #10
    Master
    Join Date
    Sep 2009
    Posts
    4,574
    > However i have the usb cable, connected it to my laptop and its not charging, just a constant red light?
    As far as I know you need the right and compatible charger in order to charge the battery.
    USB cable cannot be used.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •