Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 15 of 15

Thread: Problem charging Camileo S10

  1. Problem charging Camileo S10
    #1
    Beginner
    Join Date
    Dec 2009
    Posts
    1
    Hi all Toshiba users!!

    I've just bought a Camileo S10 camera, and it looks apretty nice, small and light. But it doesn't seem to charge the battery, neither power on. Here's how I've proceeded:

    1) I removed the insulant from the battery, and put it again, closing the case.
    2) I plugged it in with its own charger, which uses the USB connector.
    3) Circle LED around the "Record" button lights on (but doesnt blink as stated in manual).
    4) When 5 minutes pass, the LED powers off and never lights on again.

    Is this normal behaviour? Because when I try to power on the camera, it just does nothing. I tried flipping the LCD screen and also tried with power button, with USB charger disconnected. Camera doesnt react at all. When I power on with charger connected it works correctly.

    Thanks for your help!

    Message was edited by: m0sk4

  2. Re: Problem charging Camileo S10
    #2
    Hi

    The new battery is completely empty!
    Therefore you should leave the battery connected to the power for a longer time.

    Furthermore computer will not charge the battery when connected. You must use ONLY the supplied AC charger! Camcorder must be turned OFF; blinking light confirms charging but light is constant when charging has been completed!

  3. Re: Problem charging Camileo S10
    #3
    Beginner
    Join Date
    Mar 2010
    Posts
    1
    What happens if you use a different charger - ie a BlackBerry charger for the same voltage?

  4. Re: Problem charging Camileo S10
    #4
    Beginner
    Join Date
    May 2010
    Posts
    2
    *I have the EXACT same problem, battery won't charge.*
    *Camera only works when connected to charger.*

    _+*Light doesn't flash when charging as stated in manual*+_, just lights up constant for a while then goes out.

    This is very strange, a completely new camera and it doesn't even work.

    And don't tell me anything about that it has to charge for like a week, an hour should be sufficiant to at least start it up and see if it works, which it doesn't.

  5. Re: Problem charging Camileo S10
    #5
    Beginner
    Join Date
    May 2010
    Posts
    2
    The light doesn't blink when connected to charger as it should, indicating that battery is charging, only constant light and then goes out.
    Didn't you read his post?

  6. Re: Problem charging Camileo S10
    #6
    Master
    Join Date
    Sep 2009
    Posts
    3,795
    I’ve got another Camielo camcorder.
    The battery didn’t charge even if the camcorder was connected to the AC adaptor a whole night long…
    I though the battery is dead… I disconnected everything and left the camcorder for week or two… Then I tested it again… connected a AC to camcorder and guest what; the battery started to charge and everything was ok again…
    I have no idea what happened but it worked then…

  7. Re: Problem charging Camileo S10
    #7
    Beginner
    Join Date
    Jun 2010
    Posts
    1
    just been given a camileo, brand new in sealed box. It doesn't turn on. I have tried charging it and nothing, no lights, still no activity at all. Connected it to my PC and still nothing. Yes the battery is in. I've tried it with and without SD. I've taken the battery out and put it back afetr 10 minutes.
    If this is Toshiba quality, I'm not impressed.

  8. Re: Problem charging Camileo S10
    #8
    Master
    Join Date
    Sep 2009
    Posts
    2,171
    Hi zadave

    Contact your local dealer and ask for exchange. I am 100% sure you will get other one.

  9. Re: Problem charging Camileo S10
    #9
    Beginner
    Join Date
    Jul 2010
    Posts
    1
    im going away tomorrow and i've lost the charger for my toshiba camileo s10. However i have the usb cable, connected it to my laptop and its not charging, just a constant red light? Then i aslo tried plugging it into my ipod charger and then into a wall plug, but still the same thing. Will it literally not charge without the proper charger?

  10. Re: Problem charging Camileo S10
    #10
    Master
    Join Date
    Sep 2009
    Posts
    4,618
    > However i have the usb cable, connected it to my laptop and its not charging, just a constant red light?
    As far as I know you need the right and compatible charger in order to charge the battery.
    USB cable cannot be used.

  11. Re: Problem charging Camileo S10
    #11
    Beginner
    Join Date
    Sep 2010
    Posts
    1
    Hi,
    problem
    I have a Toshiba Camileo S10 camcorder and was working fine for 6-7 months and now the battery does not charge at all. Camcorder is not functioning at all.

    Is the battery charging problem due to battery drained out or is it becoz of some other problem in camera.

    I also tried starting the camera by removing the battery and tryin to charge using direct AC adaptor but it did not help. Charging through the laptop USB cable also did not work. Pls help.

    Regards,
    TPC

  12. Re: Problem charging Camileo S10
    #12
    Master
    Join Date
    Feb 2005
    Posts
    2,366
    > Camcorder is not functioning at all.
    Can you use cam when the battery is removed and you use AC power supply only?

  13. Re: Problem charging Camileo S10
    #13
    Beginner
    Join Date
    Oct 2010
    Posts
    1
    I've exactly the same charging problem with my new S10 camcorder.

    I've removed the insulating film from the battery, but when I insert it again in the S10 and I plug the charger, the LED light doesn't blink: it just lights on (in red) for a few minutes and then simply lights OFF without ever charging.

    Even with the charger connected, i couldn't power on the camera.

    How do you solved that problem?
    Did you find a solution, or you just asked your local dealer to exchange a supposedly damaged item?

    Please, let me know how you did handle that.
    Thanks.

  14. Re: Problem charging Camileo S10
    #14
    Master
    Join Date
    Sep 2009
    Posts
    4,618
    Did you read the advice posted by Tonny?
    Remove the battery and leave the camcorder unplugged for a longer time… whole night long, two days… and then test it again…
    I did it with Camileo P10 and this worked…

  15. Re: Problem charging Camileo S10
    #15
    Beginner
    Join Date
    Mar 2012
    Posts
    1
    I had this same problem! My camera is a Camileo S30. Scoured the web and found no solution. This is what I did to fix it...

    Remove battery. Unplug charger. Press and hold the power button for 20 - 30 seconds. While still holding the power button, re-insert the battery and/or plug in the charger. Voila! Came back to life and worked like nothing ever happened.

    I also did the same thing with the record button, but it was the power button that got the result.

    Hope this helps!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •