Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 2 of 2

Thread: Re: Satellite L500-1ET - Is it XP compatible?

  1. Satellite L500-1ET - Is it XP compatible?
    #1
    Beginner
    Join Date
    Dec 2009
    Posts
    1
    I don't find the model L500-1ET and its drivers. Is this model XP compatible?

  2. Re: Satellite L500-1ET - Is it XP compatible?
    #2
    Luke
    Guest
    Hi willy,

    As far as I know the Satellite L500-1ET belongs to the PSLJTE series and therefore you can find all driver on the Toshiba page:
    http://eu.computers.toshiba-europe.com > Support & Downloads > Download Drivers

    I have checked this and it seems that your model is XP compatible. You can download all drivers for XP. :)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •