Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 5 of 5

Thread: Equium L350 Beeping when Starting Up

  1. Equium L350 Beeping when Starting Up
    #1
    Beginner
    Join Date
    Oct 2009
    Posts
    3
    Hi
    I have got a Equium L350 laptop and for the last couple of months whenever i reboot the laptop or start it up the computer bleeps about 15 times before starting windows vista.

    I dont know what it means, but when it does start up the click function on the touch pad does not work (Not the mouse keys), the only was i can get the touch pad to work with a touch click is to open my web brower and search for something (using the left click button), then when i click on it it works!!!

    I know this probably sounds more complicated than it is, but i am not a great wizz when it comes to pc problems and find it difficult to explain what i mean LOL

    I have also tried restoring my laptop with the recovery disk and the same problem persists.

    This is typical when the warranty has just run out

    Any ideas anyone on what the problem is and how i can stop it making this horrid noise

    Alan

  2. Re: Equium L350 Beeping when Starting Up
    #2
    Master
    Join Date
    Sep 2009
    Posts
    4,599
    Hi

    I think this beep sound is created by BIOS.
    Usually the power on self test (POST) is running at the beginning of the booting procedure.
    http://en.wikipedia.org/wiki/Power-on_self-test

    The POST scans the hardware and search for hardware issues… if the beep sound has appeared then this means that some errors have been detected…

    But it’s hard to say what part could be affected…
    Maybe it’s a keyboard issue or RAM…

    In most cases such error can be read by ASP technician… the guys have some manuals which provide a code meaning…

    PS: Do you use the latest BIOS? If not please udpate it!

  3. Re: Equium L350 Beeping when Starting Up
    #3
    Beginner
    Join Date
    Oct 2009
    Posts
    3
    Thanks PauPau

    I have updated the bois and it restarted ok when updated, i will see what happens when i turn the comp off and then back on again, Thanks for your help

    Alan

  4. Re: Equium L350 Beeping when Starting Up
    #4
    Beginner
    Join Date
    Oct 2009
    Posts
    3
    I have now updated the bios and the machine still has the fault although it does not do it all the time, and also the touch click on the touchpad still seems to go off occasionally, do you think that it could be this which is faulty

    Alan

  5. Re: Equium L350 Beeping when Starting Up
    #5
    As PauPau suggested, an hardware issue could be the reason for the beeps… it could be generated by POST….
    I think it’s worth to get in contact with an authorized service provider…

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •