Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Satellite L300-1AQ - Fan not switching properly under Linux

  1. Re: Satellite L300-1AQ - Fan not switching properly under Linux
    #11
    Beginner
    Join Date
    Oct 2009
    Posts
    6
    I should also explain how I got the module compiled and autoloaded:

    wget ftp5.gwdg.de/pub/opensuse/update/11.1/rpm/src/omnibook-20080627-1.1.6.src.rpm
    rpm2cpio omnibook-20080627-1.1.6.src.rpm | cpio -i omnibook-2.20080627.tar.bz2

    untar, then get patch from
    http://sourceforge.net/tracker/index.php?func=detail&aid=2785886&group_id=174260& atid=868544

    cd omnibook-20080627
    patch -p0 < ../path/to/patch
    make ; make install ; depmod -a

    nano /etc/modprobe.d/omnibook
    put this in:
    options omnibook ectype=11 fan=1 fan_policy=1

    modprobe omnibook

  2. Re: Satellite L300-1AQ - Fan not switching properly under Linux
    #12
    Beginner
    Join Date
    Nov 2009
    Posts
    17
    What about omnibook svn version without the patch ? Is it expected to work ?
    Actually an echo "4" > lcd is working...but I can't do anything on /proc/omnibook/fan....

    I've also loaded omnibook with ectype=11 and fan=1 and fan_policy=1

  3. Re: Satellite L300-1AQ - Fan not switching properly under Linux
    #13
    Beginner
    Join Date
    Nov 2009
    Posts
    2
    Hello,

    I think my last reply has not been approved - if this happens again, this will be my last post here.

    Did you try Kernel 2.6.31? 2.6.32 has not been released yet, maybe there are some unresolved issues regarding that problem.

    I did not need to patch anything to get this working.

  4. Re: Satellite L300-1AQ - Fan not switching properly under Linux
    #14
    Beginner
    Join Date
    Nov 2009
    Posts
    17
    Yeah, same thing with 2.6.31 ;)

  5. Re: Satellite L300-1AQ - Fan not switching properly under Linux
    #15
    Beginner
    Join Date
    Oct 2009
    Posts
    6
    sunrider,
    I have not tried omnibook from SVN. Do you have a link?
    Thanks,
    T

  6. Re: Satellite L300-1AQ - Fan not switching properly under Linux
    #16
    Beginner
    Join Date
    Nov 2009
    Posts
    17
    Yep, just type in your terminal :
    svn co https://omnibook.svn.sourceforge.net/svnroot/omnibook omnibook

  7. Re: Satellite L300-1AQ - Fan not switching properly under Linux
    #17
    Beginner
    Join Date
    Nov 2009
    Posts
    17
    By the way, I have noticed there hasn't been any svn commit since july...it seems that omnibook development is abandoned...

  8. Re: Satellite L300-1AQ - Fan not switching properly under Linux
    #18
    Beginner
    Join Date
    Oct 2009
    Posts
    6
    Thanks, compiles fine without the patch.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •