Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 9 of 9

Thread: Slow WLAN with my Satellite P300

  1. Slow WLAN with my Satellite P300
    #1
    Beginner
    Join Date
    Mar 2009
    Posts
    5
    I bought a Toshiba Satellite P300 with Vista. I don't like Vista so I installed WXp instead.
    The trouble is that I have a very bad speed in my wireless network 1.15 mbit/second, with a another older notebook I have 10/15 mbit/sec.

    This is a problem and I don't know how to fix it.
    What network card/wireless should it be in the computer???
    After the xp installation the computer didn't find any, I've try a few things now a Atheros card is in the list.

    HELP:::::

  2. Re: Slow WLAN with my Satellite P300
    #2
    Master
    Join Date
    Dec 2004
    Posts
    1,781
    Hello

    Which BIOS version is installed on your Satellite notebook?

  3. Re: Slow WLAN with my Satellite P300
    #3
    Luke
    Guest
    Hello

    Check the BIOS as Barrie said. Maybe you should update it.

    Did you already install a driver for the WiFi card? On the Toshiba website I can find 3 different WiFi drivers for the Satellite P300. Look on the bottom side of the notebook. There you can see the model number and with this number you can choose the right driver.

    http://eu.computers.toshiba-europe.com => Support & Downloads => Download Drivers

    Greets

  4. Re: Slow WLAN with my Satellite P300
    #4
    Beginner
    Join Date
    Mar 2009
    Posts
    5
    V2.50 is the Bios version if i looked right. I have tried all three drivers..The atheros driver is thats working but very bad...
    The answer i get from Atheros was this:

    Thank you for your interest in products containing Atheros
    Communications' technology.

    However, we do not offer the wireless cards or drivers
    that you're inquiring about. Atheros typically sells
    chips to module manufacturers and therefore would not be
    able to help you with this task. For issues regarding
    configuration and usage of your product, please contact
    the card and/or computer manufacturer's technical support
    department. We suggest you refer to the manufacturer‚??s
    website, as they typically offer online technical support
    pages where software drivers, updates, and other related
    information can be obtained.

    Thank you for your understanding.
    Atheros Communications, Inc.

    This is what i see in the Device Manager
    Network:
    1394 Net Adapter
    Atheros AR9281 Wireless Network Adapter
    Marvell Yukon 88E8040T PCI-E FAst Eternet Controller

    ///Mattias Umeå Sweden

  5. Re: Slow WLAN with my Satellite P300
    #5
    Beginner
    Join Date
    Mar 2009
    Posts
    5
    The Bios version is V2.50 if i understand it right.
    I tryed all three drivers, the atheros driver is the only one whos working but bad.....

    I get a answer from Atheros and it was this:

    Thank you for your interest in products containing Atheros
    Communications' technology.

    However, we do not offer the wireless cards or drivers
    that you're inquiring about. Atheros typically sells
    chips to module manufacturers and therefore would not be
    able to help you with this task. For issues regarding
    configuration and usage of your product, please contact
    the card and/or computer manufacturer's technical support
    department. We suggest you refer to the manufacturer‚??s
    website, as they typically offer online technical support
    pages where software drivers, updates, and other related
    information can be obtained.

    Thank you for your understanding.
    Atheros Communications, Inc.

    ????????????

    In my Device Manager it showing this:
    1394 Net Adapter
    Atheros AR9281 Wireless network adapter
    Marvell Yukon 88E8o4T PCI-E fast eternet controller

    Can this be wrong or what???? I dont understand this..

    /Mattias Umeå Sweden

  6. Re: Slow WLAN with my Satellite P300
    #6
    Beginner
    Join Date
    Mar 2009
    Posts
    5
    I have tried all three drivers...the only one whos working is Atheros drivern.
    The Bios version is V2.50.

    /Mattias Umeå Sweden

  7. Re: Slow WLAN with my Satellite P300
    #7
    Master
    Join Date
    Dec 2004
    Posts
    1,781
    Hello

    On Toshiba download page you will find new BIOS update version 3.00. before download starts small notice will be shown:

    *Notice*

    *This program will check OS version and WLAN type to decide driver updating or not.*
    *1. For Windows XP image: Update BIOS only*
    *2. For Windows Vista 32 image with Atheros WLAN: Update WLAN driver (version 7.6.0.164.1 or higher) and then update BIOS*
    *3. For Windows Vista 32 image with Intel WLAN: Update BIOS only*
    *4 .For Windows Vista 64 image: Update BIOS only*

    So if you have Vista and Atheros WLAN card please follow notice number 2.

    I hope this will help you.

  8. Re: Slow WLAN with my Satellite P300
    #8
    Beginner
    Join Date
    Mar 2009
    Posts
    5
    Hello Barrie...

    THANKS:.......I did the things you say and now my internetconnection is pending between 18-22 mbit/sec....nice....

    Thanks again....

    /Mattias Umea Sweden

  9. Re: Slow WLAN with my Satellite P300
    #9
    Master
    Join Date
    Dec 2008
    Posts
    2,021
    Great news!

    If you have more questions, just start a new topic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •