Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 8 of 8

Thread: Portege M400 - batteries don't charge

  1. Portege M400 - batteries don't charge
    #1
    Beginner
    Join Date
    Nov 2008
    Posts
    4
    I recently bought a Portege M400 via a popular auction site, and all is fine except that the battery doesn't charge. The LED does not light and the machine is therefore not portable!
    I bought a replacement battery but that doesn't work either.
    It's clearly the laptop that has the problem, is there a simple fix?

    It must have been okay once!
    Thanks for any help.

  2. Re: Portege M400 - batteries don't charge
    #2
    Master
    Join Date
    Feb 2005
    Posts
    1,305
    In my opinion there is no simple fix because the battery charging is managed by board electronic (power supply electronic) and I am afraid you need professional help.

  3. Re: Portege M400 - batteries don't charge
    #3
    Beginner
    Join Date
    Nov 2008
    Posts
    4
    Hi, thanks for your input. What kind of cost is involved with professionals?
    Just a guideline, of course - how long is a piece of string etc.

  4. Re: Portege M400 - batteries don't charge
    #4
    Master
    Join Date
    Dec 2004
    Posts
    1,781
    Hi

    I think nobody here can say for sure how much the repair will cost. As you know the prices are country specific and the best thing you can do is to contact nearest Toshiba authorized service provider and ask.

  5. Re: Portege M400 - batteries don't charge
    #5
    Beginner
    Join Date
    Nov 2008
    Posts
    4
    I wonder if this is a Toshiba thing? Before I bought this I'd bought a new Equium which I really liked except that I needed a pcmcia slot rather than express (hadn't realized they'd changed).
    The battery didn't charge, even though I left it on all night before using it.
    The shop did their best not to refund me, 'I'd done something wrong, they couldn't resell it etc' but in the end had to admit defeat as they didn't have a replacement, and it wasn't resaleable in that condition anyway.

    So this is the 2nd Tosh I've bought, and with the same problem.
    It's not under warrenty so any fix will be expensive. What a pity!

  6. Re: Portege M400 - batteries don't charge
    #6
    Master
    Join Date
    Aug 2005
    Location
    Spain
    Posts
    2,282
    > So this is the 2nd Tosh I've bought, and with the same problem.
    It's not under warranty so any fix will be expensive. What a pity

    Why itís not covered by warranty? Is this laptop too old?
    If its older notebook then I would not wonder that you battery starts to malfunction.
    As Iím not mistaken after 500 times of charging and discharging procedures the battery will starts to lose the own performanceÖ so sooner or later every battery should be replaced.

  7. Re: Portege M400 - batteries don't charge
    #7
    Beginner
    Join Date
    Nov 2008
    Posts
    4
    I bought it from Ebay - so no warranty.
    And I bought a new battery last week, and the battery led does not light, so it doesn't charge.
    Everything else is fine - it's just not usable without a mains leed!

  8. Re: Portege M400 - batteries don't charge
    #8
    Master
    Join Date
    Aug 2005
    Location
    Spain
    Posts
    2,282
    OhhÖ you bought it from Ebay as second hand unit... you bought it as second hand notebook and you are 100% sure itís ok??
    Maybe the guy who sold this notebook didnít mention that something could be wrong?
    What do you think about this???

    Sorry buddy but the notebook should be checked by an technician to say what the problem could be.

    Greats

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •