Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 2 of 2

Thread: Satellite P10 cuts out unexpectedly after 4/5 minutes of being powered ON

  1. Satellite P10 cuts out unexpectedly after 4/5 minutes of being powered ON
    #1
    Beginner
    Join Date
    Sep 2006
    Posts
    1
    Hey, I am experiencing a significant problem with my 2.5 year old Satellite P10.
    The issue is that it cuts out unexpectedly after 4/5 minutes of being powered on.

    After it cuts out it WONT switch on again for approx 7-10 HOURS, even with the power lead in it displays the 4 lights at the front but it wont even power-up the Bootstrap routine.

    I have tried various power/battery combinations and I still get the same issue.
    I am sure it is overheating and then taking hours to oool down.

    Your thoughts on this would be appreciated.

    Thanks in advance...

    Ben

  2. Re: Satellite P10 cuts out unexpectedly after 4/5 minutes of being powered on
    #2
    Master
    Join Date
    May 2005
    Posts
    1,254
    Hi Ben,

    It definitely sounds like an over-heating issue from your description although I would expect it to recover much more quickly than 7-10 hours. You could try the technique of vacuuming the dust out of the air intake grilles to see if this improves the situation. Also check that the fans do work correctly and that there is enough space around the unit when it is in use.

    regards,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •