Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 4 of 4

Thread: Portege M400 - BIOS update to 1.60

  1. Portege M400 - BIOS update to 1.60
    #1
    Beginner
    Join Date
    Aug 2006
    Posts
    1
    Hi there,
    When I look for an update to the BIOS in my M400 at the Nordics version of Toshibas homepage http://nordic.computers.toshiba-europe.com - here is what I find;
    On the nordics toshiba website they have the 1.50 version available for download, while the US version website I can download the newer 1.60 version. As my M400 is a Danish version I am a little unsure as to if it's ok to update my BIOS to v1.60 now that the nordics toshiba website don't have that BIOS version available.

    Any thoughts and views about going ahead and installing the version 1.60 on my DK-version M400 is very welcomed.

    Cheers

  2. Re: Portege M400 - BIOS update to 1.60
    #2
    Master
    Join Date
    Feb 2005
    Posts
    1,578
    Hi

    Please donít compare European and US notebooks models and donít make update mix. If you have European notebook please use just the stuff available on Toshiba Europe download page.

    If you donít have problems with your unit and if operating system runs stabile, donít do anything. It is just my advice.

    Have a nice day!

  3. Re: Portege M400 - BIOS update to 1.60
    #3
    Master
    Join Date
    Dec 2004
    Posts
    2,311
    Hello

    I agree with Joao If there is no problem leave it. Bios update will be used to fix some radical problems. My unit is about three years old and runs fine with original BIOS version (factory settings).

    Anyway, if you want to check latest BIOS version please visit Toshiba Europe under http://eu.computers.toshiba-europe.com - Support & Downloads.

    Bye

  4. Re: Portege M400 - BIOS update to 1.60
    #4
    Beginner
    Join Date
    Oct 2007
    Posts
    1
    Thanks for the info both. The reason for my asking about the newer Bios (now it seems v1.70 is posted) is that I want to install Windows Vista RC1 on my M400 and have been told to be sure to use latest Bios.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •