Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Results 1 to 4 of 4

Thread: Equium A60 Power cutout after a few seconds

  1. Equium A60 Power cutout after a few seconds
    #1
    Beginner
    Join Date
    Apr 2006
    Posts
    2
    I have a Toshiba A60 notebook, but recently, after having Windows crash with the blue screen of death, I have been unable to power the unit up again. The first time it reported a problem with a PXE cable and hung, when I tried again it switched on and stopped. No screen, no POST, nothing. Now when I press the power button, it switches on for for 2-3 secconds then powers down. Anyone got any suggestions for this problem?

    Many thanks

  2. Re: A60 Power cutout after a few seconds
    #2
    Master
    Join Date
    May 2005
    Posts
    1,254
    Hi Chris,

    This sort of behaviour usually occurs because of over-heating and an internal thermal trip cuts the power to prevent damage to the unit. usually this will reset after a few minutes. The long term soultion is to clean the CPU heatsink of accummulated debris (use a vacuum cleaner hose against the air inlet grilles).

    If the power LED is blinking then there may be problems with the notebook itself and you will need to refer to an Authorised Service Partner to have it checked out.

    The reference to a PXE cable would indicate that the unit had failed to find a bootable OS on the hard drive or a CD/Floppy so was trying to boot from a LAN connection. Since the normal convention is to boot from a hard drive first this could indicate a problem with your hard drive, but even so you should still be able to power on the notebook and access the BIOS.

    regards,

  3. Re: A60 Power cutout after a few seconds
    #3
    Beginner
    Join Date
    Apr 2006
    Posts
    2
    Thanks for the response. Unfortunately there has been no joy whatsoever in powering the unit up. It will switch on for a few seconds, then power down, I have even left it for a couple of hours and went back to try again, this to failed. Is there anything else I might be able to try to get the unit powered up so I can at least be able to start solving the other problems with it?

    Regards

  4. Re: Equium A60 Power cutout after a few seconds
    #4
    Master
    Join Date
    May 2005
    Posts
    1,254
    Hi Chris,

    You can try removing the battery then connecting the AC lead and try to power on the notebook. If the power still shuts off after a few seconds then this would indicate a hardware malfunction which is being detected during the initial POST process. Sadly, without the proper diagnostic equipment it would be difficult to detect exactly what the problem was, but you could try a few things such as removing and refitting any peripheral devices (optical drive, hard drive etc.) and also remove and refit the RAM modules.

    If the unit still fails after this then you will need to refer it to an Authorised Service Agent for further diagnostic tests.

    best of luck,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •