PDA

View Full Version : Satellite Pro L850-1L4 - Can't boot from Win 8 Upgrade Disc



sealwot
17.12.2014, 16:18
Purchased just under 2 years ago. Came with Windows 8.0 Upgrade DVD.
I now wish to upgrade to Win 8 (then onto Win 8.1).

No matter what I try (BIOS changes) can’t get the DVD to boot. Under CSM boot (default for the laptop) it returns a ‘non system disc’ error.

I have tried the DVD in other PC drives which also results in the same error message.
Other disks eg Windows repair & Tosh recovery disks all boot OK.

So I think the disk must be faulty.

My question is has anyone else had this problem or even successfully upgraded using the Toshiba supplied DVD?. Getting hold of Toshiba to get replacement DVD seems an impossible task especially 2 years down the line.

Any suggestions?

Tonny
17.12.2014, 16:48
Hi

First of all please go to BIOS and set it to default (load default) settings.

Then you should switch OFF the secure boot in order to be able to boot from external media like Disk or USB flash memory stick.

Here is an very interesting thread which provides an solution to similar booting issue using the Win 8 image.
http://forums.computers.toshiba-europe.com/forums/thread.jspa?threadID=73667

sealwot
18.12.2014, 01:53
Hello Tonny

Thanks for the speedy response. This is my first post and I have already made a blunder – the laptop model is L850 – whoops (my excuse I'm a septuagenarian!)

For clarification I have the latest BIOS. The boot mode options are CSM (default) and UEFI. Only under UEFI is the secure boot option available but the laptop won’t operate set to UEFI. I did set the secure boot off before returning to CSM. This laptop doesn’t actually support UEFI, it seems the option is there just to boot a UEFI capable OS. I did try booting the Disk under the UEFI option (with the secure boot on & off) but it didn’t work.

So yes the BIOS was set to its defaults with no effect. I have found no web intelligence, generally or with Toshiba, about these upgrade discs.

The thread you provided is interesting and one element about BIOS reset to default I tried but without success.

Thanks again for your response

Tonny
18.12.2014, 11:08
Thanks for feedback

Well, probably you are right what you have mentioned in the first thread: the disk could be faulty…
Why this conclusion? You already checked different booting scenarios: with and without secure boot, CSM or UEFI mode.

Also the BIOS has been updated to the latest version…

One last idea: lets assume this Win 8 upgrade DVD doesn’t support clean installation but just an “upgrade”. This would mean that such upgrade would be started from already installed Win 7 system. In such case you don’t need to boot from this Win 8 disk but you have to start the installation within the running system. But this is just an assumption….

sealwot
18.12.2014, 16:36
I'll try that - thanks

sealwot
20.12.2014, 13:48
Solved

Once last attempt using various combinations of the BIOS boot and security settings I noticed that on one occasion after a long time with a blank screen the Toshiba recovery wizard popped up with two options ‘erase disc’ or ‘recover’. I went for recover and again for a considerable time although the DVD was running nothing showed. Then a loading files dialogue appeared. So I let it run & hey presto win 8.0 eventually loaded.

In summary > the BIOS was set to UEFI with secure boot > win 8.0 disc loaded and PC restarted > wait, however long, for recovery wizard to appear > choose recover > and wait again for installation to start. Don’t expect any reference or indication that it’s Win 8.0 that’s loading which is a bit off-putting.

Thanks