PDA

View Full Version : WiFi issue on Satellite Pro C660-2TQ - loosing connection to internet



chefrocker85
02.03.2014, 21:40
Hey folks,

hope u could help me. I did a new clean installation of Win7 (32bit)on my Toshiba Sat, C660-2TQ.

Its working fine, except of one thing:
the Realtek adapter (RTL8188CE ) in my laptop is just awful...

I installed the last wifi driver from this home preminum, but I`m losing the conn. to the internet all the time.
So that I have to manually disconnect in the right bottom corner of my laptop and connect again.
I have to this every min or so and its very annoying.

I saw read multiple threads about problems with this specific wifi adapter, but no solution helped me...

I didnt install all the drivers listet (34 available for me) yet so could it be i nedd to update my BIOS or could it be a driver like the touchpad driver is needed to get my wifi working correctly??

Hope u guys could help me...

honestly desperated

regards :)

JoeLouis
04.03.2014, 11:17
Hi

WLan disconnection issues have different causes and its not easy to say why it happens.
So you will need to check each step and option.

First of all you will get the latest driver for this WLan adapter on Realtek driver page:
[Realtek RTL8188CE driver download|http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true]


Would recommend you do install this driver.
Before you would start with new installation, uninstall the previous installed driver.

Secondly: it might be possible that this issue isnít WLan driver related and driver update would not help you a lot. In such case you should check other settings.
I would recommend you to check the router settings and to test different WLan standards (802.11 B/ G or N).

In many cases the compatibility problems between router and WLan card could lead to issue similar to yours.
Of course you should also go to device manager -> WLan card -> Properties -> Advanced tab
and should check if you could switch between the singles WLan standards (802.11 B/ G or N)
Additionally in Power management tab (last tab) you should uncheck the option which allows to disable the device to save power.

chefrocker85
04.03.2014, 15:00
thanks for your quick response mate :)

I will try out ur advices, but i wont cahnge anything in my Router settings, cause
wifi works just fine wuith all other laptops and Tablets at my place with
the used settings...

I tried several drivers, older ones and of course the newest driver, that link
u sended..the new one is installed btw...

the power saving option in the settings is already deactivated...

to be honest i really dont want to try out other options, so i am gonna spend 20Ä or so
or a good wifi-stick, so that i can deactivate this awful Realtek adapter in my Toshiba ;)

but thanks anyway ... :)