PDA

View Full Version : Satellite Pro L850-1DT cannot install Win 7 wireless driver



flenk
16.12.2013, 16:24
Please.

Upon fresh install Windows 7 64bit downloaded all the wireless drivers i can find from the tosh website.
None work.

Eventually find that in this page http://www.toshiba.co.uk/discontinued-products/satellite-pro-l850-1dt/
spec says Atheros card.

Try reinstalling the atheros driver, it gets a little way then just disappears and nothing happens.
Tried the atheros driver here too but installs but no functionality.

At one point I tried function key and F12 on and off, this seemed to enable some bluetooth stuff but no wireless.
I have "Network Controller" and "Unknown Device" in device manager with yellow exclamation marks.

Heeeeellp please.

Francesco
17.12.2013, 16:31
You are right… it looks like the notebook Satellite L850-1DT was equipped with the Atheros WLan card and therefore the Atheros WLan driver should be the right one.
This Atheros card supports also the Bluetooth feature and this that an additional driver needs to be installed to get both, WLan + BT working.
First of all you have to install Atheros WLan driver following by Atheros BT driver filter package and Toshiba BT stack.

Of course all other tools like Value Added Package for Windows 64bit should be installed too!

Hope this helps….

By the way: driver can be found on Toshiba EU driver page
http://www.toshiba.eu/innovation/download_drivers_bios.jsp?service=EU
Here you have to choose Satellite Pro L850 PSKDHE

flenk
08.01.2014, 13:18
Thank you very much Francesco_1.

I don't quite understand why the bluetooth part of things, whether it is installed or not, would affect the wireless LAN. Causing it to not work.

I have tried what you suggested but the BT zip file appears to be corrupt/broken in some way.
I have downloaded it on 3 separate occasions all with the same result.

Upon extracting it with either WinRAR or 7Zip I get a message telling me it is corrupt or an "unexpected end" or contains an unrecognised file type !

I have also tried finding a driver using the Windows Update, again to no avail.

Appreciate any help anyone can give me.

JoeLouis
31.01.2014, 16:33
> I have tried what you suggested but the BT zip file appears to be corrupt/broken in some way.
>I have downloaded it on 3 separate occasions all with the same result.

Here is a direct link to the [Toshiba BT stack version: 9.00.00T|http://cdgenp01.csd.toshiba.com/content/support/downloads/tc00442200b.exe]

flenk
05.02.2014, 21:26
Hi JoeLouis,

Thanks very much for that download link.

It did indeed properly install all the Bluetooth stuff.

But it did not have any effect on the wireless LAN/NIC part, it still sits there in device manager with an unresolved yellow exclamation mark against it, saying the drivers have not been installed for this.

I have again tried to install the Atheros driver using the setup file but it starts to install and then simply ceases to be there, as in the installation process seems to cease and all evidence of it simply disappear.

I have tried the 2 Atheros files I can find - TC00384500B & TCA0079900A.
The first of these appears to install but makes no difference.

The second one is the one that disappears.

The first one also had a folder with some inf files so I have tried installing by trying to update the driver from device manager using these inf files but I just get cannot install, windows says no etc.

I am now getting to the point where I am considering reinstalling Windows all over again; again ! and then trying to install the wireless driver before I do anything else.

Can anyone tell me _exactly_ which driver and util files I should download for this particular computer ?
And in which particular order I should install them ?

Thanks.

JoeLouis
06.02.2014, 14:14
Hi Flenk

Thanks for feedback regarding the BT driver.
Indeed the BT stack installation does not solve the WLan issues…

You are asking what driver you need for this Wlan card.

The WLan card is an *ATHEROS 802.11 (A/G/N) WB222-HMC*
You should find the prober driver here:
http://aps.toshiba-tro.de/wlan/index.php?page=downloads

I guess the +Atheros Wireless LAN Adapter for Windows 7 (32/64) v9.2.0.419.0+ should be the right one.

flenk
13.02.2014, 19:29
Hi JoeLouis,

Thanks for your help, and indeed thanks to everyone who helped.

I tried the link you gave me but again to no avail, so I wiped the whole system and reinstalled Win 7 all over again.

Then, on a known fresh system the very first thing I tried was to install the wireless driver you pointed me to but again to no avail.

So using the info you gave me about the WLan card I tried to check to see if the card installed in the laptop was indeed the same one - it was very difficult to see as I had to look sideways underneath the casing after taking off the bottom access cover.

The Card said Atheros Model AR5B22
I was tearing my hair out and couldn't believe that none of the drivers I had tried or any of the drivers that you guys on here had pointed me to worked!

I tried to do some looking about the WB222 (AR5B22) and found that it is AKA AR9462 Mini PCIe.

After some more searching about I found that the Aspire M3-581T has this very same WLan card in it so went to the A.c.e.r website to see if I could download a driver from there - it is listed there as AR5B22.

Downloaded both the WLan and the BT drivers.
"*_HOORAY - SUCCESS_*"

So if anyone else is having the same/similar problems, this fixed it for me and I suspect will also fix it for someone else too.

Thanks again for all your help and regards to all.

JoeLouis
14.02.2014, 09:55
Great news!
Thanks for feedback!