PDA

View Full Version : Continual loss of wireless connection with Satellite C660



glengoz
21.08.2013, 21:22
Hi,

I am hoping someone out there might be able to help.

I have had my Satellite C660 for about 18 months now. Since day one we have had continual problems connecting to the wireless network. It connects but then loses connection again a couple of minutes later, then after a few more minutes it re-connects. And so the circle goes on. An Ethernet cable didn't improve matters.

Initially the problem was resolved by leaving the laptop charger plugged in, randomly this solved the problem and although not ideal, I went with it because it worked.

We have just had new broadband and router installed and the problem has now re-occurred, but this time the power cable fix doesn't work, and yet again an Ethernet cable doesn't work.

The laptop now continues to lose connection and it is very frustrating. I have 2 other Dell laptops, 2 tablets and all of them work fine, never losing connection.

Can anyone please give me some advice as to what could be causing this problem and how I fix it (easily!).

I look forward to hearing your thoughts and thank you in advance for your help.

Glenn

Tonny
02.09.2013, 10:37
>Initially the problem was resolved by leaving the laptop charger plugged in, randomly this solved the problem and although not ideal, I went with it because it worked.

I think the WLan disconnects due to power saving.
As you said, connecting the notebook to main resolve the issue. I think due to the AC adaptor connection, the notebook switches to another power profile where the Wlan power saving is disabled.

Therefore I recommend to modify the power profile which is used in battery mode.
Control panel -> power option -> choose the power profile which you are using in battery mode
Now choose “change advanced power settings”
Here you will find an option called “wireless adapter settings” (or something like that)
Both option “battery mode” and “Ac adaptor” should use the settings “performance”

RandyRoberts
17.09.2013, 15:26
I agree with Tonny, try to change the power saving settings in power options.
Additionally go to device manager and expand the Network controllers area.
Here you would find the LAN and WLan card.
Go to Wlan properties and switch to last tab called Power Management.
Here you should uncheck the option which allow to disable the device to save power.
Repeat this procedure also for LAN card as well.

It’s also advisable to update the WLan driver.

JeroenB
18.09.2013, 14:53
Hey I also have a Toshiba Satellite c660 myself (2.5 years now i think) around the date this post was made I'm also having issues with my wireless connection.

When I use my laptop +- every hour my laptop disconnects from the internet, and immediately connects again.
I use my computer often to play online games and after 3 weeks it is starting to get on my nerves, because I need to restart the whole game etc..

Never had any problems with my wireless connection.

Jeroen