PDA

View Full Version : No wireless on Satellite C660d-14W after clean Win 7 intsallation



Ellm62
08.01.2013, 15:15
Hello,

I bought a toshiba satellite c660d-14w off a friend, and reinstalled a clean copy of windows 7 x64.
After installing, the laptop didn't recognize any hardware (graphics, sound, wireless network card) so I've been slowly trying to install all the drivers for them all.

However, no matter what I install for the wireless, it just doesn't seem to work.
Have installed the realtek RTL8188CE driver, the wireless lan driver from the Toshiba website, and have set the network connections service to auto and restarted it and still nothing.

In device manager, under network adapters, I have two entries:

Realtek PCIe FE Family Controller
&
Realtek RTL8188CE Wireless LAN 802.11n PCI-E NIC

Both say they are working correctly and have the latest drivers but I have no access to wireless, the icon doesn't show in the tray, and i just get a generic error message from windows when trying to manually set it up.

Please help!

Paolo30
08.01.2013, 15:42
Yes, the WLan card seems to be recognized properly in device manager.
The Satellite C660C-14W supports the Realtek RTL8188CE WLan chip.

You said that you have no access to the WLan…
Did you check the availability in
Control panel -> Network sharing center -> Change adapter settings (on the left)

Here you should see the WLan card
Is it visible?

If yes, go to Properties and uninstall the TCP/IPv6 protocol and use just the TCP/IPv4

Ellm62
08.01.2013, 15:49
Hi, yes the card is recognised in Change adapter settings, and I've unticked TCP/IPv6, but still no icon in t he tray. When I right-click "Connect" it just brings up a notification by the sys tray saying I'm connected to the internet, but there's no wireless at all.

On clicking 'Diagnose'; the results state 'Windows couldn't automatically bind the IP protocol stack to the network adapter.'

Message was edited by: Ellm62

Paolo30
08.01.2013, 15:57
Try to use the command ipconfig /renew in the cms (command dos box)

Also try this:

Control Panel > Administration Tools > Computer Management > Services & Applications > Services.
Scroll down this list to find 'WLAN Auto Config'
Double click on 'WLAN Auto Config' On the general tab, select from the start up type drop down menu, select 'Automatic'. Under Service Status click on 'Start'. Then 'Apply' these settings and exit from all open control panel windows.

Otherwise uninstall the Realtek driver in the device manager.
Then reboot the notebook.
Download the Realtek WLan driver again and install it.

Ellm62
08.01.2013, 16:06
Tried the first two suggestions to no avail. Should I only uninstall the realtek WLan in device manager, or both of them?

Paolo30
08.01.2013, 16:15
The other entry means Lan card so if just the WLan card is affected, i recommend installing the WLan card only.

Ellm62
08.01.2013, 16:28
On reboot, after uninstalling the WLAN driver, Windows detected it was missing and used Windows Update to reinstall the realtek WLan driver again, but still no wireless in the tray, and no connectivity. Any other suggestions?

Paolo30
08.01.2013, 16:32
Don’t let the Windows installing the Wlan driver automatically.
You have to download the Wlan driver and have to install this manually!

Ellm62
08.01.2013, 16:55
Still nothing, installed manually and still no wireless status in the system tray, still says enabled in Adapter settings in control panel, but won't connectm just shows the notification that I'm connected by the ethernet cable.

Paolo30
08.01.2013, 17:11
So remove the LAN cable, enable the WLan using the FN buttons FN + F8
and test it again...

otherwise I think you've got an problem with the system and maybe you should re-install it again,..,.

Ellm62
08.01.2013, 18:25
Yep, went nuclear and reinstalled windows, although I feel like I shouldn't have had to...

Anyway, so I had the realtek LAN driver on USB and installed that after Windows reinstalled, got internet access, and then I just let Windows Update download and install everything it wanted, including the WLan driver, and *everything now seems to be working* :)

Message was edited by: Ellm62