PDA

View Full Version : Satellite P755-11Q - WiFi bad reception



glor
20.12.2012, 21:53
hello.

I have a new satellite p755, with W7 64bit.
I own it for almost a month now, after 4 years of using a satellite A500 18Q. my old laptop is still working and here starts the problem.

we have a wireless connaction at home. both my old comp and my brother's comp have a full reception at most places of the house.

my own new computer has half a rece[ption at best, a room away from the router, and if I go further, I cant get a connection at all. the drivers are the newest in existance, and I'm at the end of my wits.

Is the network card of poorer quality than that of the old A50? what might be the problem, and how can I solve it?

the card, as far as I can tell, is an Atheros AR9002WB-1NG Wireless Network Adapter.

furthermore, when the computer comes back from hybernation, (using system continue) it works really slowly, and it takes almost 10 mintues for all the wondows open too actually work.

I bought iths new computer to get a better user experience, as my old comp is 'tired' and ready to retire. but so far, it is mainly a source of frustration.

please help.
thank you.

JoeLouis
21.12.2012, 16:48
>Is the network card of poorer quality than that of the old A50? what might be the problem, and how can I solve it?

Don’t think the quality is poorer… there are different Wlan cards on the market and every chip support different specifications…

In your case I would try to change the 802.1 standard… to B or G

Try to change also the channel…
As far as I know this can be done in device manager -> Wlan card -> properties -> Advantage tab

Disable also power saving for Wlan card

glor
22.12.2012, 17:59
hey, thank you for your help.

so, you say I must go back on reception protocols in order to get better reception?
my network is a good one, of N protocol and wide stripe. it irks me to have to reverto to a weaker connection, and not be able to make full use of my existing network. I tihnk, when buyin a new computer nowdays, that having to do that is a shame.

as for power saving mode, I did shack that and disabled all the power saving properties, as well as that 'allow this device to disconnect' thing.

is there no way I could use my network fully without having to revert to older protocols?

EDIT: after looking at the advanced tab in the wlan card manager, the only option I have, and its currently enabled, is the B connection. so its already B and I cant even change that to N or G if I wanted to.
is that even logical?

Message was edited by: glor