PDA

View Full Version : Satellite L855-149 - Synaptics touchpad not working after Win 8 upgrade



simonbrown94
17.11.2012, 18:05
I hare recently upgradedmy Toshiba Satellite L855-149 to the most recent windows 8 version 6.2 and since I have done so the Synaptics touch pad has stopped working, I presume because the driver does not work with this version of windows 8. What can i do to resolve this problem so that i can use my computer without a plug in mouse again?

Thanks,
Simon

vincentpretet
20.11.2012, 00:28
Hi Simon !!
I have just clean installed windows pro 8 on my satellite r830 and i had the same problem (actually, the touchpad still worked but not the scrollbars).
What you need to do is download the driver via this website, unzip it and execute it. It will work just fine. Locate it under 'windows 7 64 Bit' (or 32 Bit, depending on your OS) and not 'Windows 8 - Upgrade' as synaptics still hasn't realized a specific driver to windows 8.
Use the assistant on the website to find the proper driver faster (the reference of the model is written on the back of the laptop)
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/home.jsp
So far, it's the only driver that i have installed. However, the button near the touchpad that activates or deactivates it still doesn't work. Maybe it will work again when i install the other drivers.
I hope this can help you ;)

simonbrown94
20.11.2012, 01:52
Thanks I installed it and the synaptics touch pad worked for about 30 seconds after the restart and then died again with no indication as to why. Any ideas about that??

Thanks,
Simon

Akuma
20.11.2012, 07:43
Was it happening in Windows 7 has well?

Maybe it's a hardware problem. Or perhaps you are pressing F5 by mistake which toggles the touchpad on and off.

simonbrown94
20.11.2012, 17:07
No it isn't a hardware problem, I bought the laptop with windows 8 pre installed earlier this month and it only tarted happening when there was an update on Saturday. But as it turns out that F5 thing worked a treat and it is fine, I had no idea about it :P

Thanks,
Simon

Tonny
20.11.2012, 17:12
Thanks for feedback!