PDA

View Full Version : Satellite Pro L770-149 - Cannot get Wlan working



Dale-9999
24.09.2012, 12:27
Hi

I have recently rebuilt a Toshiba Satellite Pro L770-149 with windows 7 64bit, when i first installed the operating system, all the drivers were missing so i installed all the correct drivers and got it running like it was before. Apart form the wireless connectivity,

It can connect through an ethernet cable and the wireless is enabled (Fn+F8).
On device manager it shows that all the drivers are correct and working.
The icon on the taskbar just stays as a red cross unless i plug in the etheret cable.

Any Suggestions

Thanks in advance for any help

JoeLouis
24.09.2012, 13:37
I think the notebook support the Atheros 802.11(b/g/n) AR9285 WLan chip.
Did you see the Atheros Wlan card in device manager?

If yes, the Wlan card driver is installed properly and if you enabled the WLan card using the FN + F8 then you should be able to configure the WLan.

For that you have to go to control panel -> Network & Sharing Center -> (on the left) choose Manage Wireless Networks
Now choose Add -> manually create a network profile
Here you can configure the Wlan using SSID and other necessary options.

Dale-9999
24.09.2012, 14:24
Yep its in there, and its configured.

But it still doesn't see any wireless networks, its asif the WLan card is disabled, but i know that it isn't.

Every now and then the wireless networks flash up but then disappear again. and im unable to get them back

JoeLouis
24.09.2012, 14:33
> its as if the WLan card is disabled, but i know that it isn't.

Are you sure the WLan is chosen and not BT?

Dale-9999
24.09.2012, 14:37
How do you check that?

JoeLouis
24.09.2012, 14:39
How?
I think you should see the icons while pressing the FN + F8
There you can see if its BT or WLan…

Dale-9999
24.09.2012, 14:47
Its WLan.

JackyStewart
25.09.2012, 10:19
Did you install the Atheros Bluetooth Filter package?
This filter package is needed to get WLan and BT supported by this one module.

Dale-9999
25.09.2012, 14:39
Yep i have just installed the atheros bluetooth filter package,

but hasnt solved the issue.

JackyStewart
25.09.2012, 16:29
Very, very strange… now I see just one solution: take your recovery disk and set the notebook back to factory settings. Then test the WLan functionality once again :(