PDA

View Full Version : Satellite A210-27M (PSAELE) cannot use new Wlan card



roshkovanv
23.01.2012, 11:54
Hi all,

I changed my wi-fi nic to an Atheros AR5b91 and hardware is locked.
I can't remove this lock from wi-fi switch or fn+F8 probably it's bios lock.

I tried to unlock it on Windows Vista, Windows 7, Ubuntu so it's not caused by software.
I tried wi-fi nic on other notebook(not toshiba) and it's ok.

Can somebody help?

Thanks

Paolo30
23.01.2012, 12:13
Hi

For me it looks like you used not compatible Wlan module.
But I found these thread:
http://forums.computers.toshiba-europe.com/forums/thread.jspa?messageID=79237

One user could not enable new upgraded Intel Wlan card.
According to some info, its possible to enable the Wlan card by covering the pin 13 on the miniPCI wlan card.
But to be honest I never tried this and I would use this workaround with caution.

assex
23.01.2012, 22:50
Out of curiosity, is this WLAN card compatible with your notebook?
Was your old card defective?

roshkovanv
24.01.2012, 13:34
This not works for me :(
probably the only solution is to use new bios.
Maybe this solution will work for others, so I need to mention that my notebook uses *mini pci express* so there should be disabled pin #20
http://icelord.net/HP/pin20.2.jpg

Message was edited by: roshkovanv

Feliks
24.01.2012, 23:56
>probably the only solution is to use new bios.
Toshiba doesn’t offer BIOSes that allow you usage of some additional (newer) hardware. New BIOSes offer some small fixes and not more than that so, in my opinion, BIOS is not the solution.

roshkovanv
25.01.2012, 14:51
"Toshiba doesn’t offer BIOSes that allow you usage of some additional (newer) hardware."
Yes, so I modified my bios and removed white-list check. And now I can insert any wifi nic :)

Tonny
25.01.2012, 15:26
thanks for the feedback!