PDA

View Full Version : Satellite L500 - WLAN Adapter disappeared from device manager



Flooba
08.12.2011, 11:06
Hi guys, I've read a lot of threads but not found a working answer to my problem yet, although this does seem to be a common problem, so I was wondering if anyone can help me out. Laptop model is L500-1VT. There is no external WiFi ON/OFF switch.

In brief:
-Woke laptop up from sleep, previously before its nap had connected to wifi, but suddenly had no connection.
-Adapter did not appear in control panel, so checked device manager. Not there. :S

-Thought maybe something had come loose? But then checked msinfo32.exe and adapter was seen there.
-Read lots of threads about this being issues with TVAP and FCU, so followed advice doing reinstalls, and uninstalling and reinstalling wlan driver (this lost it being seen in msinfo32.exe.) Sadly this did not work. Still not seemingly visible to windows.
-Fn + F buttons have never worked and after reinstalls of above programs still do not work.
-Wireless is enabled in the bios.

-However, and I don't know if this is the crux of the problem; *wireless is OFF in HWsetup.exe. When I try to turn it on, it says reboot needed. If I do this straight away, or a lot later, I get a blue screen and memory dump.* So I'm pretty sure this is a software issue.

-I've also tried system restores and microsoft repair disks. But I'm at a loss at what to do now, so am using my phone's WiFi through USB to connect atm.

If anyone has any ideas, that'd be great!

xaver
08.12.2011, 23:29
Hello

Does WLAN work when you restart your notebook?
Is latest BIOS installed on your Satellite notebook?
Have you tried to update BIOS too?

And yes, last question: do you use original OS that you got with your notebook (recovery image)?

Flooba
09.12.2011, 10:49
Hi,
No WLan does not work. I have done multiple starts and left battery and power supply out for ten minutes before switching on and no luck. Bios and OS (win 7 32) are what originally came with the laptop. I have uninstalled HWsetup and all the other packages, and reinstalled the wireless driver and still no luck.

I'm thinking at the moment I'll probably just have to do a fresh install, but would like to avoid this if possible.

I will try a bios update now, as that is something I haven't done.

Cheers.

Flooba
09.12.2011, 12:10
Yeah, BIOS update didn't work.

maherP
11.12.2011, 07:07
I have the same problem, card not showing up in device manager. It is a Realtek 8191SE wireless card, it wont show up in system information however unlike yours.

I have done everything i can think of! New driver, complete registry clean, BIOS update, etc etc.

No joy!

Dr.Lamp
13.12.2011, 09:35
> I have done everything i can think of!
Recovery installation too? Best way to check hardware functionality is to install original operating system that you got with your notebook (WIN7 64BIT HOME PREMIUM). If the same problem occurs with “factory settings” than there is hardware problem.

MisterX
13.12.2011, 15:21
Hi guys

The Latest Realtek drivers can be downloaded here:
http://aps2.toshiba-tro.de/wlan/index.php?page=downloads

If the WLan would not appear installing the driver from Toshiba driver page, please recover the notebook using Recovery disk in order to check if it’s not hardware problem!!!

Akuma
14.12.2011, 05:38
Hi,

Did you run Recovery recently or order discs from Toshiba?

What is the model number of your L500? (The PSxxxx-xxxxxx number)