PDA

View Full Version : Cannot reload WLan Atheros AR5007EG on Satellite L350D



Giedo
27.11.2011, 14:23
I am using a Satellite L350D model PSLE8E-038002BT.

As I had a network problem (I regularly lose contact with the DNS server), I suspected the driver atheros-wlan-win7-9204190 which I had recently installed to be the cause. I wanted to go back to the version atheros-wlan-win7-8002580 which had ran successfully on my PC for quite a while.

So I went to ‘Device management’, chose for ‘Network adapters’ where I selected the Ahteros wireless. Selecting ‘properties’ and ‘device drivers’ I tried to reload the old version. As the old driver was not saved at this location I used the TC00190600I.exe file from the zip file received using Tempro. Unfortunately, the Atheros loader refused to overwrite a new version by an old one. As a result I decided to remove the driver, which also removed the Atheros device from the system.

I recovered the device by starting the TC00190600I.exe again. But the connection to the router does not come up. The icon at the bottom of the screen indicating connectivity says : ‘Not connected, there are no connections available’. The windows network control mentions ‘Possibly there is a problem with the device driver for your wireless network adapter connection.’

Note that some texts or names mentioned above cannot be accurate. I translated them as I use a Dutch windows version.

Thanks for any help or advice.

Giedo
27.11.2011, 15:21
Please note the following additional information :
I just installed on this PC an Wireless USB adapter of USRobotics. I supposed this would be a good bypass. Unfortunately he gives exactly the same problem as with the Atheros internal adapter : ‘no connections available’ and ‘possible error with the driver’.
This makes me suppose I do not have a problem with the driver or the adapter. At the other hand I have no idea where to look now.
Kind regards
Giedo

Silas
27.11.2011, 23:51
> This makes me suppose I do not have a problem with the driver or the adapter.
Ok and what is with your router?

Have you tested WLAN connectivity somewhere else?

Giedo
28.11.2011, 10:02
Thanks for reaction.

The router works OK as 2 other PC's connect wireless without problems.
About testing at other location, normally I also see the routers of some neighbours, now no connections are found.

Giedo

assex
29.11.2011, 00:13
Maybe you must change some WLAN settings on your router.
Is your WLAN secured? Test it without WLAN password.
Change WLAN mode, play a bit with settings. It must work somehow.

Restart the router.

By the way: do you use original OS that you got with your notebook (VISTA 32BIT HOME PREMIUM)?

Giedo
29.11.2011, 21:14
Hello,

As you can read in my answer from yesterday, this problem is router independant. Normally I see about 5 routers from different neighbours, with different protection, now I do not see any router. Detecting the router is done at a lower level in the protocol stack as security negotiation.

About the OS, I used the by Toshiba and Microsoft proposed upgrade packagee to go to Windows 7.

Kind regards,
Giedo

assex
29.11.2011, 23:19
I don’t know what are you doing exactly and how you have installed all these updates.

If you are 100% sure that this problem has nothing to do with your router install original recovery image and test functionality. If everything works properly with “factory settings” than you will know for sure that WLAN card is working properly and it is not hardware related issue.

BTW: few days ago I had strange problem on my old A300 (Win7 32bit). Suddenly notebook could not establish connection to my WLAN router. Router was visible, password correct but nothing. I’ve tried everything but nothing helps.

At least i have restarted router and suddenly everything was OK. Why?

Giedo
30.11.2011, 22:27
Before restarting from an old recovery dvd,I wanted to go back to a system recovery point. This failed. After research I found to remove Zonealarm and retry.
As soon as Zonealarm was removed, I saw the router again. I reconfigured the atheros card and evrything is ok.

Although I do not know, and probably will never know what happened I close this question

Regards

assex
30.11.2011, 23:11
Thanks for the feedback. :)