PDA

View Full Version : Satellite C660 - Cannot enable WLan after Wlan card replacement



Klubba
16.11.2011, 22:46
since i need bluetooth i swapped the Realtek RTL8188CE in my C660 for an Intel Centrion 1030.

Now i have bluetooth working fine, but i can't get wifi working :(, drivers installed nicely but i cant switch it on/off using Fn F8, and the intel program that came with the drivers says "Hardware Radio switch is off"

I tried swapping back for my old wifi card and then magically wifi shows up in the Fn "Flash Cards", with no drivers installed for that card or anything, but when i use the intel card i have no wifi among the "Flash Cards".

Is there any way i can force the wifi switch on?,

the latest bios i found for the C660 is 1.8 and thats the one i have installed.

xaver
16.11.2011, 23:55
The whole story is somehow confusing for me.
Has your notebook “factory settings”?
Since when you have noticed this problem? I cannot imagine you have it from the day one.
Have you installed latest WLAN driver from Toshiba page - http://aps2.toshiba-tro.de/wlan/?page=downloads ?

New notebook is delivered with preinstalled OS and properly configured hardware so it must works.
I’m afraid you have screwed up something.

Klubba
17.11.2011, 07:46
Your message contains profanity or inappropriate language. In the interests of your fellow forum users, we would ask you to amend your message.
Can not get past this to reply. No idea what its reacting on tried 10 times or so.

Klubba
18.11.2011, 21:39
Found a fix.

Pin 20 on the mini pci-e port controls wifi on/off, pin 20 is energised when wifi is off so by taking the wlan card out, taping over pin 20 and sticking it back in, my wifi is now active and i have both BT and 300mbit wifi working nicely. So in the end it turned out to be a really sweet 10$ upgrade ;D