PDA

View Full Version : [SOLVED] Satellite L750 Wireless wifi off after recovering from standby



no_user
15.06.2011, 16:23
I set wireless connected automatically in "Manage wireless networks", however, after starting Windows, I can see the computer is trying to connect for a few seconds, then a red cross go on the top of the wireless tray icon. I have to press Fn+F8 once (Flash Cards showing Wireless WIFI is on) to turn "On>>Off", then again to "Off>>On" in order to connect to a home WIFI network. In addition, the LED light of Wireless is always off while the Wireless network is well connected as I could access the Internet.

And if I don't do the trick to turn off then turn on, the network diagnostic function could never fix the problem.

Can you give me some idea to solve this annoying problem of having to press Fn+F8 a few times?

Cheers

Andy

PauPau
15.06.2011, 17:22
Hi

In my case the Wlan is always enabled if I enabled the WLan previously using the FN + F8 option.
So it’s not known to me why you have to use this combination once again if the Wlan was enabled in the first step.

However, maybe a WLan driver update could solve this…
Check the newest Wlan driver for your WLan card from this page:
http://aps2.toshiba-tro.de/wlan/

C3PO
16.06.2011, 15:29
Hello

That’s strange… After standby or hibernation the WLAN is always working as usual. I never noticed a difference…

I could imagine that something is wrong with WLAN driver so I would recommend a WLAN driver update as PauPau suggested. You can download this on official Toshiba WLAN portal.

By the way: Can you post some information about your OS and BIOS version?

guest
19.08.2011, 05:22
I had same exact problem you had. I had to use fn and f8 to turn on and off. I also did not have the wireless light. I did a lot of searching and this fixed my problem. My first attempt was to download the realtek driver from the toshiba website which didn't fix it.

Then I went to [Realtek homepage|http://218.210.127.131/] and searched for the driver for my realtek wireless adapter. *This worked.* I have the wireless light working and it picked up the network right away. *No red x through the signal bars.* I hope this helps.

Roffee
06.12.2011, 18:34
I'm having the same problem.

I re-installed the driver,but no difference
I disabled the option to out the card to sleep (in power management W7)
I disabled ip6

Still I have to do the annoying fn+f8 thing each time the computer boots or wakes up.

No light in wifi led on front, not even whenwifi is working

Machine tries to install bluetooth driver,buts hangs on each attampt.

Beside this issue, the machine is ok, but I can't stand this longer. Had the machine for a week, and it will probably be returned to dealer if I can't fix this.

MisterX
07.12.2011, 17:39
> Still I have to do the annoying fn+f8 thing each time the computer boots or wakes up.

The annoying FN + F8 option enables and disables the Wlan and BT or switches between mentioned options.
But the Fn buttons are controlled by VAP (value added package) and Flash Card Support Utility… so it’s recommended to reinstall both tools…

> Beside this issue, the machine is ok, but I can't stand this longer.
Maybe the BT installation cannot finish because the BT is disabled by FN + F8

However, it would be interesting to know if the HDD recover would solve all these issues because it smells like OS issue and mostly reset to factory settings solve the system issue

mtarbin
11.12.2011, 03:12
Hi,

I too have an L750 which has the same problem. I.e. Adapter is disabled on boot or after waking up and the wireless LED not lit when connected. The adapter I have is the Atheros AR9002WB-1NG

I tried the following to no avail:

1. Checked the BIOS to ensure it is not disabling the adapter.

2. Checked all the power saving modes/settings.

3. Re-installed the drivers from both the Toshiba web site and from the Applications and Drivers in the Toshiba directory. I have not been able to download from Atheros though as I can not find any links.

4. Re-installed the VAP and Flash Card Support Utility as per MisterX reply.

I am at a loss to know where to go from here. The machine is only a few weeks old and was working ok to start with. The functionality is all there, but it is rather frustrating having to use the FN+F8 function to enable it each time.

Any help would be appreciated.

Dr.Lamp
11.12.2011, 13:36
Hello

Check please the latest BIOS update on Toshiba support page. Do you have latest BIOS version?
If not try to fix this with BIOS update.

mtarbin
12.12.2011, 08:08
Hello and thank your for you reply.

I have checked for a BIOS update from the downloads page for my model, but there appears not to be one, nor does it identify what the version should be. So I am unsure if it is the latest. I assume that it is as no update is available. The version that I have is 2.40 08/24/11

Tonny
13.12.2011, 12:25
> The functionality is all there, but it is rather frustrating having to use the FN+F8 function to enable it each time.

So this means that WLan works properly and you can connect to the WLan but you have to use Fn + F8 in order to switch ON the WLan card each time the notebook came from stand by. Right?

Go to device manager -> Wlan card -> Properties -> Power Management and remove the mark from the option called: +Allow the computer to turn off this device to save power+

mtarbin
14.12.2011, 06:15
Hi Tony and thank you for your input.

You are correct in your understanding of the problem. The Power Management option is unchecked, but the problem persists.

Tonny
15.12.2011, 15:48
I’ve got an idea.
The internal Atheros card shares the WLan and BT functionality.
It could be possible that there is some issue

Would recommend doing this:
- Remove the BT stack (in control panel -> software)
- Remove the Bluetooth Filter Driver Package (this driver is needed to enable Bluetooth on your Atheros wlan-combo-card.)
- Remove the Wlan card driver
- Reboot the notebook
- Clean the OS using CCleaner (freeware software)
- Download install the Atheros WLan driver (http://aps2.toshiba-tro.de/wlan/)
- Reboot
- Download install Bluetooth Filter Driver Package (from Toshiba European driver page)
- Download install Toshiba BT Stack (http://aps2.toshiba-tro.de/bluetooth/)
- Reboot

mtarbin
24.12.2011, 07:43
Hi Tony,

I have done as you have suggested, but to no avail. Unfortunately the Bluetooth drivers will now not load either. Really not sure where to go from here except do a complete re-install of Windows.

macbook51
02.01.2012, 06:23
I might have a solution to this annoying problem of the wifi hardware not working after sleep. I tried reinstalling all suggested software from this forum but nothing work.

What worked for me was to remove the laptop battery and unplug the power adapter. Then I held the power button down on the laptop for over thirty seconds. Reconnect everything again and wifi should now work automatically after sleep hibernate and restart. Let me know if that works for you. Good luck!

nborshukov
03.01.2012, 10:33
Look at this: http://support.microsoft.com/kb/978258

mtarbin
04.01.2012, 20:06
I have now tried just about everything including updating all the drivers and software; applying patches and hotfixes; re-installing Windows to the "out of box" state etc, etc.

The solution?
Well for me anyway, it is as you say Macbook51, it is as simple as disconnecting the power and pulling the battery out!!!!!

Not sure if holding the power switch down is important or not, *but I now have the wifi LED illuminated, the Bluetooth drivers have loaded ok and everything is back to normal.*

Thanks to all those people that have contributed and of course a big thanks to you Macbook51.

siggyd
01.08.2016, 00:19
Had the same problem, L745-S4235 ,no wireless indicator light after windows 10 ?? ,tried all kinds of upgrades. had to do the FN OFF/ ON , OFF/ON every time to
connect. Then I read to pull the battery with all power OFF for 2 min...........It works now A OK.
Siggy