PDA

View Full Version : Satellite C660 Wireless stopped since BIOS 1.4 Update



cosb6
23.05.2011, 22:00
Hi,
I'm hoping someone can help me with a new problem with my Laptop.

I have a Satellite C660, and when it was new had some issues with the Wireless, and it not working when disconnect from the Mains. This was resolved by downloading the latest drivers from the REALTEK Website, and all has been perfect since until a couple of days ago.

The TOSHIBA Bullettin Board advised of some critical updates, and I followed the steps given. This I believe has updated the BIOS to version 1.4

Since then, I cannot get WIRELESS to work at all. It says it's enabled, I've reinstalled the latest drivers, but to no avail. It simply says there's no WIRELESS CONNECTIONS AVAILILABLE. I've used another laptop and confirmed the wireless network is fine (indeed I can pickup many other in the area with my old laptop).

Having done all the tests, I cannot get this working at all.

Can anyone advise if it's a problem with the BIOS Update, or if there is any simple way of testing if it's simply a hardware fault. The Laptop is only a few months old, so any advise most welcome.

Thanks in advance

Stuart

cosb6
23.05.2011, 22:04
The message when trying with the Network Cable unplugged is;


"There might be a problem with the driver for the Wireless Network Connection 3 adapter"


All attempts to reinstall drivers, follow all prompts, etc, has failed.

Could it be faulty hardware? Is there a test?

Thanks in advance
Stuart

Paolo30
24.05.2011, 11:28
> All attempts to reinstall drivers, follow all prompts, etc, has failed.
>Could it be faulty hardware? Is there a test?

Hmm…according to this message the Wlan driver was not installed properly.
Maybe you should uninstall the Realtek driver and should install it once again after registry clean.
So please check the latest driver from here:
http://aps2.toshiba-tro.de/wlan/?page=downloads
or from Realtek page.

By the way: after BIOS update its recommended to set the BIOS to default.
Check this… in some BIOS versions, the Wlan option is available in the BIOS settings… so please check this too!

cosb6
26.05.2011, 22:38
"install it once again after registry clean"

Do I have to do anything to clean the registry, or will that happen when I do the UNINSTALL of the driver.

I will have a go at running the downloaded ZIP file, and see how it goes

Stuart

Xardas
27.05.2011, 08:36
Hi cosb6,

>Do I have to do anything to clean the registry, or will that happen when I do the UNINSTALL of the driver.
Therefore you should use a registry cleaner like CCleaner:
http://www.piriform.com/ccleaner

The uninstaller removes the most files but sometimes not all registry keys will be deleted. This can make problems so it’s always advisable running CCleaner from time to time.

cosb6
28.05.2011, 10:17
"Driver Device Software was not installed correctly"


"Please consult with your device manufacturer for assistance getting this device installed"

Network Controller : FAILED


So,,, whatever it is, uninstalling / reinstalling didn't seem to work.


Any more advise what I might be doing wrong? Could it be a hardware failure?

Thanks in advance
Stuart

C3PO
28.05.2011, 11:15
Hello

And did you already try CCleaner as Xardas suggested?

If it doesn’t work it seems to be a software/driver issue. Something has muddled up the OS and/or driver installation.

What you can do is removing the old WLAN driver in safe mode. Start Windows in safe mode (F8 key before Windows start then select safe mode). Now try removing the WLAN driver and then restart your notebook. Boot into normal mode and try installing the WLAN driver again.

If it still doesn’t work I would try a recovery installation. Follow these instructions to restore the original factory settings:
http://aps2.toshiba-tro.de/kb0/HTD9102IR0000R01.htm

JayBee007
01.06.2011, 01:20
I also have updated my Bios on a Toshiba Satelite C660 and on reboot have lost my wireless connection - the wireless is showing up as turned on and the Broadcom Network adaptor is showing up correctly in the Device Manager.
Any suggestions? Is there a way to roll back to the previous Bios version?

Jon

martinf
21.06.2011, 01:33
The exact same happened to me.
After Bios 1.4 installation, wireless connection was lost.

Like JayBee007 the adaptor is showing up correctly but no connection can be established.
I have installed the latest drivers and adjusted power options, which seems to have been an issue with some Toshiba Satellite laptops, but I've had no success.

Nice laptop, very happy with it besides, one week old, and may have to be returned if no solution can be found. Would very much appreciate any help with this matter.

P.S. JayBee, as far as I know the Bios update is irreversible.

Paolo30
21.06.2011, 13:47
Hi

After the BIOS update, you should access the BIOS, should set it to default.
Then visit the Toshiba Wlan portal and download the latest Wlan driver.

At this time it’s version: v5.60.48.35
http://aps2.toshiba-tro.de/wlan/

Install this new version, reboot the notebook and then go to power management of Win 7 and disable the power saving for Wlan!
Furthermore go to device manager -> Wlan card -> Properties -> Advanced tab and check if you are using the same standard 802.11 like the router.

martinf
21.06.2011, 16:26
Hi Paolo,

Thank you for your reply. Today I contacted Toshiba Technical Support. I gave them remote access to my computer in order to determine what the problem was. The technician spent almost an hour trying to figure out what the problem was, but unfortunately he could not find a solution. He tried driver downloads, setting Bios to default, adjusting power options etc. but he had no success. He came to the conclusion that it is a hardware issue, and has arranged for the laptop to be repaired. I will post here with further developments as they arise.

xaver
21.06.2011, 17:04
Very interesting feedback.
I’m very interested to hear what the problem is.
Waiting for your feedback.

martinf
28.06.2011, 17:35
Ok, so today I got a phone call from the company who performs repairs on Toshiba's behalf. They told me that it is not a hardware problem. They removed the wireless card, put it into another machine, and it is working without any problems. They said there must be some software issue and advised me to restore the machine to its original factory state. I really hope this solves the problem, otherwise I'll be left with a brand new laptop with no wi-fi connectivity. :/
P.S. Has anyone any ideas what might be causing this problem? All the drivers, bios etc. are up to date, but some software appears to be disabling, or blocking, wi-fi access. Ethernet connection is fine. I have both avast anti-virus and zonealarm installed. Could either of these programs block wi-fi access but not a LAN access via an ethernet cable?
I would really appreciate any thoughts or suggestions.

Thanks,

Martin

martinf
01.07.2011, 00:22
Good news, I'm sending this message via my wireless connection on my Toshiba c660!

*I restored the machine to factory settings and my wi-fi connection was immediately re-established.*
As CP3O suggested above, something must have got muddled in the O.S. following the bios update.
I guess that makes it a windows error.
It's a bit of an irritation, having to re-install everything again, _but at least the problem has been solved._

Thanks to everyone for their help and advice.

Martin

MisterX
01.07.2011, 09:30
Thanks Martin for sharing this with us!!