PDA

View Full Version : WiFi fails to connect when Wep enabled - Satellite L350



silver
19.10.2009, 20:57
Hi

I have a Satellite L350. On day 1 of purchase, wireless connection was OK. Updates to OS Vista Home Premium started automatically and SP2 now installed. Now unable to make wireless connection when WEP enabled on Router (3Com Office Connect ADSL Wireless 11g Firewall Router. Error message suggests security settings of network adaptor (Atheros 5007EG) are incorrect.

I have reset them many times and reset the encryption on the Router many times. Nothing works.
The adapter can find my network SSID but will not connect. However if I switch off WEP connection works.

Cable connection to Router works OK

Driver for adapter is reported as latest.

Can't think of anything else to do.
Advice please.

Paolo30
20.10.2009, 09:30
Hi

This is definitely an encryption issue…
You should check your router configuration again…

This means tat you should try to change the kind of encryption; instead of WEP try to use WPA.
This should be changed on router and in WLan configuration settings…
Check if you could configure the WLan using Atheros WLan configuration tool…
But if you would do this, please don’t forget to switch OFF the internal Windows zeros config.

TwoLags
20.10.2009, 09:53
Hi silver_2,

I agree with Paolo30. It must be definitely an encryption issue.

But I don’t understand why you want to use WEP encryption. This encryption isn’t sure and can be cracked in few minutes. You should use WPA or new WPA2 encryption if your notebook does support this.

Anyway, try it again without encryption or WPA. Furthermore firmware update could be also useful.

silver
20.10.2009, 16:40
Hi

Many thanks. However, tried WPA, reconfigured router/wireless adapter but problem still there.

Macius
20.10.2009, 16:52
Have you installed SP2 following automatic Windows update?
Maybe you have installed new WLAN driver offered by this update.

On my notebook I have Atheros WLAN card and one driver update is listed as optional update.
I have immediately removed check mark in front of this update.
Have you done the same or the updates are set to be done “automatically”?

silver
27.10.2009, 12:34
Hi
I think SP2 was automatically installed when I switched on the first time I connected to the Internet. After that first automatic update WiFi stopped working

Paolo30
27.10.2009, 20:50
Hi

Repeat the whole router configuration and configure the WLan again…
Use the configuration tool like Atheros WLan configuration Utility or Intel ProSet Tool.
These tools allow you to configure the WLan and provide more option as the Windows Wlan zero config.

PS: ensure that your BIOS is up to date!