PDA

View Full Version : Tecra A4: Wlan Intel 2200bg not stable with 802.11 G WLan



raynerph
17.08.2009, 19:48
With the latest driver re-installed (9.0.4.39), I've found that a connection to a "g" network was unstable. (Slightly better than before re-installing, when it would connect to a "g" network but not pass any data.)

With both a BT Homehub and now a DLink DSL-2640R router (TalkTalk), I have found that one way to get a stable connection with the latest driver is to set the router to use only "b" networking. But this is slower.

Until I got a different router (recent change of telco provider) I had just assumed it was a BT Homehub problem (believe me, I had spent some time trying to resolve it!). However, now that I have tried two routers and found the same problem, I thought it might be an issue relating to the setup of the laptop...

I've kept the many wireless driver downloads that I've installed, and tried to think back to happy time when both laptop and homehub were happy to communicate on a "g" network. So I went back to driver version 9.0.4.17, and guess what, all the problems have gone away with the new router and it's happily connected to a "g" network.

Normally the advice is to use the latest driver version, so why would I have success with an older driver. What have I done wrong? I tried different types of encryption available and it hasn't affected the problem.

I've got the box ticked to allow windows to configure my network settings. I while ago I did try using the Proset Software, but that stopped the ConfigFree from running properly so I went back to the original set up.

Does anyone have any suggestions as to what I need to do to get a stable connection to a "g" network with an Intel 2200bg with the latest driver (9.0.4.39)? I'm wary that I may run into some other issues if I continue to use the older driver?

Akuma
25.08.2009, 02:15
There are always compatibility issues with Wireless products, especially when connecting with different brands. Manufacturers are constantly updating the drivers to fix issues, but sometimes it can introduce problems with older Adapters such as the 2200BG.

First thing to do is update the firmware on your Router, then update the drivers on the Wireless Adapter. If later drivers don't work, it wont hurt to revert back to a previous version.

You can also try changing the Advanced settings in the Wireless Adapters Properties in Device Manager. For example, try setting it to "802.11g only", try a different channel, try different power settings, etc..