PDA

View Full Version : Problem Not connected to WLAN when power on



tnguyen
11.08.2009, 16:44
computer Satelite 355-s7905, Atheros AR5007EG - driver 7.6.1.x , Vista Home basic, Belkin router F5D6231-4 - 802.11b, Norton Antivirus.

When I power up the computer, the WLAN icon indicates connected with limited access (no connection!). Windows indicates my WLAN device is working properly. I check the driver and it is up to date.

To connect, I have to go to control panel, disable then enable the driver. Once it got connected, it stays until I restart or shutdown. But when I turn computer on again, the same problem occures. Again, to connect, I have to manually recycle diable/enable the driver.
Does anyone know what may cause this problem? Is there anyway to fix this? Please help. Thank you.
Tien

Paxan
12.08.2009, 15:20
Have you tried the previous version of the Atheros driver on your PC?

Also, it is worth checking your Belkin router wireless configuration:

I.e. is the Hidden SSID off? What is beacon interval?

The other thing to try is to change your wireless channel in Belkin Router configuration (your PC adaptor should pick it up after change anyway). If there is another source of signal, it can interfere with your wireless network. You can check this using Toshiba's ConfigFree "Search for Wireless Device" utility.

tnguyen
16.08.2009, 03:37
Thank you Paxan.
Problem solved.
turning off the hidden SSID does not seem to fully fix the problems. after many tries and searches, I finally got it work.
The solution for my problem is to disable the IPv6 (window Vista) and configure Norton antivirus to allow IPv6 application to pass through. Apparently, Norton Antivirus was blocking some processes that use the IPv6 protocol when it tried to connect tho VLAN. that was my guess though.

tien